UIFlow 1.7.3

  • @iamliubo I'm glad to here that you're going to work on the PaHub problem. I think that is important for the user community to know that there is someone looking at issues and working for fix them. It may takes time to fix an issue but if I know that someone in M5Stack is working on it I'm happy and I can wait.

  • @sparkgene @IAMLIUBO Why is the AWS blocks greenyblue in those pictures but yellow on my screen?

  • @ajb2k3 I'm not sure, but first it was blue. The latest is yellow(orange?) on my screen too. BTW Try to use the latest uiflow image v1.7.3.1. The error "aws isn't defined" will be fixed.

  • @sparkgene I solved the AWS not defined issue as it was due to incorrect placement of the Start block.

    I'm just back to the "Cannot create thread" error and completely lost.

  • So Now it works ( Had a permission issue on AWS) however I have an issue with the AWS blocks.
    @IAMLIUBO return topic doesn't return the topic and there is no return topic payload block.

  • @fonix232 said in UIFlow 1.7.3:

    A kinda related, but strange question - could you please release the source code for the drivers of the various bits of hardware found in the UIFlow firmware? UIFlow is built upon MicroPython, and I would personally prefer to run a clean MicroPython build on a few devices of mine, however the lack of drivers makes it a bit harder than expected. I'm not interested in the UIFlow-related parts, just the low level Core/Unit/Module support drivers (e.g. for M5Paper, a driver for IT8951, a driver for the PMIC, SHT30, GT911). It would allow the community to build MicroPython images without proprietary code, and possibly result in faster updates as well. Plus, you could merge back community fixes into the official UIFlow firmware easily.

    Same thing for me.
    But I like uiFlow tool to test the code.
    For example, Update the UIFlow-code project on git with core2 libs would be cool
    Best reguards

  • Hello,
    I have same issue with MQTT using Core and Stick in UIFlow 1.7.3. In Core, I downgraded firmware to V1.4.5 and work, but i cant do same configuration with Stick.

  • @iamliubo how can we help to see M5stack go OpenSource?
    The devices are great, but software will be boosted in a large way.

  • @titimoby
    This is not something I can decide, but we will wait until that day :) (Maybe soon

  • @iamliubo May I ask you if you are part of M5Stack staff?
    Not to bother you, just to understand the M5 ecosystem ;)