• Trying to get an M5Dial working with the M5Stack GPS unit in UIFlow 2.0.2. The Dial doesn't have a blue "Port C", but have tried setting up a UART on Port A and B with absolutely no luck. Unfortunately, the screen on the Dial is round, so the error messages are cut off in the top corners. Starting with a blank UIFlow project, adding a label on the Dial, just so that I know something is there, I can "Run" successfully, label shows up. Adding an "Init gps_0", fails with gps.py line 22 "ESP_ERR_NOT_FOUND". I've tried to use the UART blocks to initialize port 15 and 13 to a UART, but that fails with "ERROR: UART buffer size is fixed... (can't read the rest, off the screen)". @felmue indicates the UART blocks may be broken, so I've tried an "Execute mpy code uart1 = UART(1, baudrate=9600, bits=8, parity=None, stop=1, tx=15, rx=13)", but also get an "ESP_ERR_NOT_FOUND" for that, too.

    Anyone tried a GPS module with M5Dial yet? Or otherwise get a GPS to work on an ESP32-STAMP-S3 based core in UIFlow2? Or even successfully set up a UART?

  • Hello @BrianR

    Hmm, does the Init gps_0 block (w/o GPS connected) also give you an error? I don't have the GPS unit so I cannot do a complete test. But simply execute the Init gps_0 block w/o anything connected to port A doesn't give me an error.

    I you want to try with UART then I think you got tx and rx reversed, try port A with tx = 13 and rx = 15.

    And you are running UIFlow 2.0.2 firmware on your M5Dial. correct?

    Edit: I've created an UIFlow2 example M5Dial_GPS_Unit_UIFlow2.0.2 which works for me. (Note: I used the GPS from the Atomic GPS to test with; it seems to send a compatible serial data stream.) You can find it in the UIFlow2 Play Zone.


  • Uiflow 2 uart setup/init blocks are broken in some way,
    best is use "execute my code" block with uart setup as per uiflow1

    see below thread

    uiflow2 uart

  • Eureka! I'm not sure why I didn't try this before, but I just burned UIFlow 2.0 for Dial, v2.0.1 to my Dial and attempted the GPS example that @felmue made and it works! With 2.0.2 I continued every combination of things, including setting up the UART as in the M5CoreS3_UART_PortC_UIFlow2.0.1 example, but as soon as I put that "Execute mpy code" in there, regardless of what the actual code was, it errored out.

    @felmue , thanks so much for making a project zone example for me! That example is up and running on my dial now. Thanks so much for taking the time to help this community!


  • Hello @BrianR

    glad to hear you got it working. And thank you for reporting back.