UIFlow 1.4.5

  • @ajb2k3 said in UIFlow 1.4.5:

    @m5stickfreakler You mean offline version?

    Yes I mean offline version :-)

  • hmm small bug with Button ? At Atom Matrix

    There is only one button :D

  • M5Stack

    @mati thanks your feedback , we will fix it as soon as possible

  • @robalstona said in UIFlow 1.4.5:

    Connect the atom to the computer and connect to it with the terminal program, system information along with the API key are displayed during startup. The second option is to keep the matrix button pressed while starting until the colors change pulsatingly. And release it when it is pink / purple. then the atom will launch its access point. Connect to his network via address and then in the browser you will see the API key and you will be able to choose the network to which you will connect.

    Thank you it works :-)

    Greetings skink

  • @m5stack Can you get the RGB LED blocks removed from the Hardware section of blocks and move the to the Base/Module section please?

  • why would people above say that pink/purple is the config mode? after flashing 1.4.5 for me the yellow mode is the config mode...

    after flashing 1.4.5 neither online (breathing green mode) nor offline ide works for me... absolutely not...

    usb mode (blue light) does nothing for me...

    i could only flash firmware and that's about it... pretty useless, no? still a facepalm for me at this point...

    and btw what is "app run mode"?

  • M5Stack

    @illusion were you able to connect to wifi? offline wont work yet as the link for uiflow desktop hasn't been updated to 1.4.5 on the website, You cant upgrade it within the software either

  • @illusion said in UIFlow 1.4.5:

    and btw what is "app run mode"?

    When you start atom in app mode after boot a file main.py is running. In this file you can save your program which will be run. You can save your program from UiFlow by "Download" button/icon. Then your program should be saved as main.py and after restart device should be run it. But i did not tested by this way on atom (on StickC works as i wrote up). I wrote this file by another software.

  • Some issues about UIFlow 1.4.5/ on Atom Lite/Matrix :

    • using CLI (Command-Line-Interface) tools (on Linux), 'screen /dev/ttyUSB0 115200' on Linux works, showing 'MicroPython v1.11-301-gd0880874d-dirty on 2020-03-13';
    • but 'rshell' and 'ampy' don't work at all (these tools are useful to manage files on MicroPython microcontrollers). Exemple of error message : 'ampy.pyboard.PyboardError: could not enter raw repl';
    • so how to copy files to/from the internal flash memory of Atom Lite/Matrix ? I don't see webrepl, ftp server, etc, in the 1.4.5/ firmware.

    While using :

    • Atom Lite/Matrix with pre-installed firmware (MicroPython v1.12-36-gf68fe753b-dirty on 2020-01-14), 'rshell' and 'ampy' work without problem;
    • M5StickC with UIFlow 1.4.5/, 'rshell' and 'ampy' work too.

  • Could you try uPyCraft. I use them on windows system and i can transfer files to/from Atom Lite/Matrix with burned Uiflow firmware. Under linux where i use Linux Mint 19 uPyCraft i cannot run it (problem with installing proper libraries needed to run)

  • M5Stack

    upyloader is another good solution for transferring files to the flash. Ampy hasn't worked for me for a long while

  • Thanks for both suggestions. I've tried uPyCraft on Linux and it works.

    But then I've remembered Thonny. Tried it and it also works on Linux and has many features for MicroPython @ Atom Lite : View->File, edit file on microcontroller flash memory, etc.

    I also recommend mpfshell, it works 100% on Linux to copy files with Atom Lite/Matrix & UIFlow 1.4.5(.1).

  • Since a few days an entry in a MAP of UIFlow is not entered in the MAP. In the Blockly view the entry is present, in the Python view it is missing. All other entries in this MAP are present.