Connection problems



  • Hi folks

    I have often a connection problem to my m5stack device.
    If I upload a program to the device and something goes wrong, I cannot connect to the device again.
    I have to close the Windows UIFlow and start up again and load code again.
    This problem occurs very often and it is very annoying.

    Software:

    • Firmware UIFlow-v1.4.5.1 (also with v1.4.5)
    • Windows UIFlow 1.0.8.1

    It seams to be a blocking of the com port by the Windows software because if I try to burn the firmware I get following message:

    Command:
    --chip esp32 --port COM4 --baud 921600 --before default_reset write_flash -z --flash_mode dio --flash_freq 80m --flash_size detect 0x10000 application_0x10000.bin 0x1000 bootloader_0x1000.bin 0x200000 fatfsImg_0x200000.img 0x8000 partitions_0x8000.bin 0xf000 phy_init_data_0xf000.bin 0x3ff000 wifi_0x3ff000.bin
    ===================================================
    [3288] Failed to execute script esptool
    Traceback (most recent call last):
      File "esptool.py", line 2849, in <module>
      File "esptool.py", line 2842, in _main
      File "esptool.py", line 2549, in main
      File "esptool.py", line 213, in __init__
      File "site-packages\serial\__init__.py", line 88, in serial_for_url
      File "site-packages\serial\serialwin32.py", line 62, in open
    serial.serialutil.SerialException: could not open port 'COM4': PermissionError(13, 'Access denied', None, 5)
    esptool.py v2.5.0
    

    After restarting the windows UIFlow everything works fine for a while.

    Does anyone have a better solution?

    Best regards
    Thomas