M5Stick c USB mode

  • Hello,

    I get some M5Stick C. I have the same Problem. After istalling the Firmware for UIflow 1.3.2 UIflow will connect the Stick C but after 3-4 seconds ist will be disconnect no way will connectet it again.
    The Wifi-way is not able for me. My LAN-Router works on this adress. Is there any way to connect the M5Stick C via USB or change the IP-Adress of the Stick ?

  • @Peter what computer are you using?

    What do you mean by "IP is not accessable?"
    Have you tried to connect to the isolated network it creates?

  • Hello ajb2k3,

    thanks for repy.

    I'm working with a Win 10 computer. M5Stack Core works fine. The Problem is the M5Stck C.
    My private Network with some PC's, NAS's an Printers work on 192.168.4.x and the router to the Internet and wlan accespoint to the Internet has 192 -168.4.1. To change this networkadress ist a hard work.

    To try it with an old Handy i must leave my Haus to test it. I does not yet.


  • From what I understand is the host address of the network master. After initial setup where you connect the stick to you network, the modem should reallocate an address as the stick is no longer a master device and is now a slave.
    My modem does.

  • Problem partial solved :)

    I put my old Handy and the M5Stick C very near together. So I can recive the Config-Site from the Stick and put it to login in my home Wlan.

    Now I can program the Stick with http://flow.m5stack.com/ :))

    But what is with USB?


  • @peter There is an offline version of UIFlow that you can use to program the M5Stick when set in USB mode but you can also access the M5Stick and run Micropython in repl over usb mode.

    Glad you got it working now

  • Sorry to hijack this thread but I was about to post a new Q to ask something similar

    @ajb2k3 Could you point me in the direction of how to write micropython scripts to the m5stickc over USB? I'm up and running with UIFlow but I'd quite like to just use my own editor and just run a bash script to write my python file to the device.
    With the UIFlow firmware guides I didn't find much information on doing this directly over USB.
    I'm on Linux btw.


  • @ss4f11 have you checked out the micro python website? At present I haven’t written a guide on it.

  • @ss4f11 There are a few options. Option 1: Use microsoft vscode and download the m5stack plugin which allows you to write python scripts with auto complete features, and then run them directly from the computer to the stick or put them in the flash and then run them. It also allows you to easily copy other kinds of files to the flash and see what other files are already in the flash. Check out this video for getting setup https://www.youtube.com/watch?v=Y9pOWgsNgKk&t=11s

    Option 2:
    Use your favorite serial terminal program to connect to the REPL of the device, I use "screen" on linux the command should be something like:
    screen /dev/ttyusb0 115200

    From here you can poke around with micropython commands and see the direct results on the device. Then once you've had your fun kill the processes with Ctrl + A + \ and install ampy https://github.com/pycampers/ampy

    ampy is a tool which allows you to put and get files from the flash and run them directly on the stick from the terminal. I did 2 videos some time ago about this https://www.youtube.com/watch?v=V67MY-1ccqM

    You could also use rshell or upycraft

  • [M5StickC] How to switch to USB mode
    (Japanese webpage please google translate :p)

  • Now all work fine!

    Tank's flypeek for the link to the japanise Site. I don't anderstand japanese, but I get an Inspiration. I have to push ButtonA an Reset together - now i see the Menue :).

    Tnx to all helpfull user.


  • @peter said in M5Stick c USB mode:

    Now all work fine!

    Tank's flypeek for the link to the japanise Site. I don't anderstand japanese, but I get an Inspiration. I have to push ButtonA an Reset together - now i see the Menue :).

    Tnx to all helpfull user.


    If you view the page in google chrome than chrome will translate it for you.

  • Thank you for the Tip with Google Chrome. I use Firefo. There was no translation. But now I have try out something and all works fine.

    Thank you all together :)


  • @peter Sometimes you have to right click to get the translation function and sometime the page needs reloading. I view a lot of Chinese and Japanese pages and have noticed lately that the translator doesn't always appear.