Experiencing Multiple Firmware Issues

  • I just received my M5Stick in the mail last night, and unfortunately I have encountered multiple issues regarding the firmware.

    1. The M5Burner refused to download any of the available firmwares while running on my MacOS Mojave partition. The program just glitched out every time I hit the download button next to the firmware. I had to switch to Windows for this function to work.

    2. Once I was able to download firmware, I initially tried UIFlow v1.4.4, however this version failed to properly execute, bricking my M5Stick. I had to install v1.4.3 to get anywhere.

    3. I have been unable to REPL into the device. Using MPFShell, I opened the port that it detected, then tried to initiate REPL, but the program just kept giving me this error:
      "Could not enter raw repl, Press Reset key after 5 seconds.”
      I did as it asked, to no avail.
      I also tried REPLing in in Windows via putty, but again nothing.

    #1 seems like a bug with the Mac software that is causing it to not connect to the servers, but I’m hoping for some insight on #2 and #3 at least.

    Thank you.

  • M5Stack

    Hi @AP1290 Sorry to hear that you were having these issues. I believe I should be able to help you with most of these issues.

    1. Due to the nature of how the UiFlow software is developed for MAC, it requires that you place the uiflow app into the applications folder. Only then will the firmware function work.
      You may still have issues with burning the firmware to the StickC though as I have. I tend to prefer using esptool to burn the firmware https://github.com/espressif/esptool as I find it's much more stable.

    2. There are known issues with 1.4.4 and 1.4.3 which haven't been fixed yet due to staff being away on chinese new year holiday. Best to wait a while and I recommend using 1.4.2 for the best results.

    3. I am not familiar with MPFshell I tend to use the standard screen terminal on mac, first finding the port with ls /dev/tty.* and then starting a terminal session with screen /dev/tty.usbserial-xxxxxxxx 115200 you need to make sure uiflow is closed or any other program which is trying to access the device over serial. If the issue persists, try unplugging and reinserting again or switch to another usb cable

    Hope that helps, let me know if it works for you

  • Thank you so much!

    Yeah, that resolved all my issues. I was still a little confused with the REPL at first, until I realized that I had to reset and use a keyboard interrupt (actually three interrupts before the REPL finally came up).

  • I also had a problem connecting to the console with m5stickc. I only managed to connect when I selected and run the TEST program from the application menu on m5stickc

  • There is a Bug (If you can call it that) that if you initiate a connection to repl but the terminal app fails, the connection is held open and you will get the
    Could not enter raw repl, Press Reset key after 5 seconds.
    Unable to establish connection
    Errors. I am not sure what the cause of them is but closing the command prompt/terminal will NOT close the connection or reset the device.
    Unfortunatly after all this time the driver is still flaky (not M5Stacks fault) and sometimes needs to be installed in a very specific way.

    Unable to download firmware is due to a connection issue with the server. not knowing how the server was built, its hard to say what the error is but often it is down to too many people trying to access the server at the same time.

  • M5Stack

    A few other tips. If you want to transfer files to the flash of the device press ctrl + a + \ to kill the terminal session and processes running, this will allow you to now transfer files using ampy, personally I prefer upyloader now as its much more convenient. Also when your finished with your terminal session press ctrl + a + d to detach the device, this will help to avoid the "pty not found" message when trying to start a new terminal session or any issues with using uiflow over serial after closing a terminal session

  • See my post here, with UIFlow 1.4.5/ on Atom Lite/Matrix, 'ampy' and 'rsheel' tools don't work at all.

  • M5Stack

    see my suggestion in your other post, last time i tested I could use vscode with m5stack plugin to transfer files to the atom on linux os. Be aware it must be in usb mode, this video explains how to get into USB mode https://www.youtube.com/watch?v=4dr5Y5ssQTk