Silicon labs CP210x driver not working on my Mac with Catalina OS( version 10.15.4)

  • Hello there,
    I can't get the Silicon Labs USB to UART driver to work on my Mac. I heard that some earlier version(s) of the driver were working but not the latest one. Does anybody know where I could het a version compatible with Mac OS Catalina 10.15.04 ?
    Thank you very much for your input.
    Kind regards.

  • @pumpui With Catalina you need to use a usb hub between the m5stack and the osx computer. there are loads of issues with cat and hardware

  • Hello and thank you for your reply. By " hub " you mean a hardware adapter ?
    Thank you.
    Kind regards.

  • @ajb2k3 Hello again, how would I wire that ? Yes indeed lots of people are having loads of problems after installing Catalina. Many application sofwares sotted functioning and companies are very slow updating to this new MacOS. So frustrating

  • @ajb2k3 Hello again. I am now really stuck. I have been talking to Siliconlabs which, of course, claim that the issue lays in the target hardware. It could very well be, however whats intrigues me is that when I run the => ls /dev/tty* from Terminal the driver does not show up in the list. This after having been " successfully installed" What should I make of that ?
    As a go around (and out of frustration) I wanted to install the driver and IDE on an old Windows machine I have laying around. Unfortunately it runs Windows Vista. To upgrade to Windows 10 requires a completely new installation, which I can't do, for I need to keep this machine as is for other applications. I imagine I could buy a USB to UART adapter but this too requires a driver, which might very well not run on Catalina. It looks like lots of people ran into this snag and yet(apparently) nobody has come up with a solution.

  • There are several things to try.
    1st is to use a USB hub between the M5Stack and the Mac computer.
    2nd, is to use a different cable.
    3rd is to use a different USB programmer to bypass the CP210x chip.
    4th is to try the tips the other catalina users have posted on this forum.

  • @ajb2k3
    Hello Sir, thank you for your reply. With regards to your suggestions :

    1. use a USB hub. Yes however a hub is a piece of hardware which needs a driver to function. To date the only driver people are talking about is the one supplied by Silicon Labs, which simply doesn't work with Mac OS Catalina V 10.15.4.I have seen other USB hubs but the drivers run only under Windows-
      2nd) use a different cable, the cable I have been using with my previous Mac and this Mac(before I upgraded to Mac OS 10.15.4) was working just fine.The only thing that changed is the Mac OS version.
    2. I am not sure what you are referring to here, isn't it the same as point 1 ?
      4)the driver doesn't even show up in the list of installed drivers( terminal command => ls /dev/tty*) I doubt that writing wiring a capacitor, pull up or pull down resistor, etc.. would help at this stage.

  • @ajb2k3 Would using the USB M5 Stack module solve the problem temporarily ? Or this port would not be usable to program the Core ?
    Between us, I am very surprised to see that M5Stack doesn't step in to solve an issue many users of their products are experiencing. I never had such issues with Arduino or ESP boards. Frankly if in 2020 one has to fight with prototyping boards in this manner something is wrong in the scope of delivery. Thank you very much for your inout Sir. Michael.

  • I have these archived files on my Mac if you want to try them:
    SiLabsUSBDriverDisk.dmg dated Jan 6, 2018
    SiliconLabsUSBDriverDisk.dmg dated Jan 23, 2018

    If you want to try the files, Direct Message your email and I'll email it to you.

    I'm on Catalina 10.15.4 and have no issues burning any of my M5stack products (grey core, fire core, m5stick, m5stickC, atom matrix). I always use the official Apple USB-C Digital AV Multiport Adapter on my 2015 MacBook Pro and a USB-A to USB-C cable (sometimes reversing the USB-C side orientation (i.e. "flip it over") if the driver doesn't seem to detect the device).

    It may be due to the fact that I installed the Silicon Labs drivers many years ago when I first started the M5stack journey. However, along the way, there have been issues with OSX that have required me to fix/patch things.... most recently with the m5stickC/m5atom driver patch (Solution2 from this thread).

  • @world101 Hello and thank you so much for your input. This is exactly what I mean, the whole thing is esoterical. Sometimes it works, sometimes it doesn't and one doesn't know why, this drives me crazy. I will be happy to try some of your archived driver files. Actually I am at the point where I'm considering purchasing a cheap Windows lap top and dedicate it as a the development environment. There are several useful software packages which don't run on Mac OS. A double boot with parallels is expensive and gobbles a lot of disk space. There are cheaper alternatives but they only run standard Windows applications. Not wanting to be the Beta tester on that one :-)

  • @world101 said in Silicon labs CP210x driver not working on my Mac with Catalina OS( version 10.15.4):

    (i.e. "flip it over") if the driver doesn't seem to detect the device).

    (i.e. "flip it over") if the driver doesn't seem to detect the device) <= in my case the Mac doesn't even see the Siliconlabs driver as being present. How do I "direct email you Sir ?

  • @world101 I want these files, could you send me? I will send you my e-mail in private chat... thanks!

  • I've just upgraded to Catalina and the driver worked first time.