[SOLVED] Arduino IDE on Windows won't flash

  • Hi
    I had problems using arduino IDE with a Fire board on a windows 7 laptop (got time out error)
    I tried many solutions, including updating the COM driver, using command line esptool, or installing OTA on arduino IDE
    Every solution does work ONCE, the first time, and then won't work anymore
    It is the same on a windows 10 desktop, but I found out that everything was ok on my old Debian laptop
    So my question is : is arduino IDE really usable on windows machines ? Is there a "hack" I should know?

  • No, its the com port driver. Windows and OSX insist on users using the included broken driver and so kill the driver from the download page.
    The most optimal way to get things to work involves several "Cold Starts" of computers. A "Cold Start is where the hardware is powered off and left for a minimum of 3 mins to allow the capacitors in the ram to discharge, fully wiping the ram of retained data.

    1, Delete existing com port driver,
    2, Switch off and cold start machine.
    3, Install driver,
    4, Switch off and cold start machine.
    5, Connect M5Stack cores and check the device managers for errors and that devices are recognised.
    6, Switch off and cold start machine.
    7, wait for machine to finish loading (give this 5 to ten minutes), then try connecting M5Stack BEFORE loading Arduino.

    IF you reinstall arduino or any other IDE/Programming environment, you MUST Switch off and cold start machine before starting to program.

    This is not a flawless method but is the most reliable method to get the driver to work on Windows and OSX!

  • Thanx a lot, it works!

    What if I use windows 10 and WSL (linux inside windows) ? Will I avoid driver problems ?

  • No drivers needed for stickC and atom on linux, but you need to know what you're doing to allow access to the usb, e.g. add permission for non root user, this could be especially tricky if using linux in a virtual machine.