Several issues with your new M5Paper

  • Recently I got the new M5Paper and I run into several problems. Via the standard Arduino IDE I can upload the example programs SHT30 and BUTTON, both of which work.

    I can compile the example HelloWorld without errors, but after the upload I only see a blank screen. Same problem with M5EPD_TTF and TOUCH.

    How is that possible? Am I doing something wrong or did I buy something that is not yet properly developed and is everything still premature?

    Furthermore, I would like to restore the test as installed at the time of delivery. On GitHub I see the files under M5Paper_FactoryTest, is this the right software? It seems intended for PlatformIO but as many others I don't use that and hope you can tell me how to restore the factory demo from Arduino IDE.

    Help is appreciated!

  • @m5hans I have similar experience. I can run all examples and my programs, but sometimes the M5Paper freezes just after restart. It helps me to send it just again. Try to send the examples few more times if it helps. The Factory test and few more expamples are made in VSCode. It could be possible to change the sources for Arduino, but I would suggest you to try VSCode. The IDE is bettere and compilation faster and it is not difficult.

  • Thanks for helping,Martin! It seems to me that the issues with blank screen after upload are over after I reinstalled the board in the board manager, maybe I did something wrong or the computer, presumably me ;-)

    Do you mean by VSCode PlatformIO? Then we talk about the same, the software from M5 is indeed intended for that. But, sorry to say, I hate PlatformIO so I hope for another upload from the M5 folks, software that is easy to upload with the Arduino IDE.

  • If you simply want to restore the Factory Test, you can use the M5Burner software.

  • Just installed M5 burner and I did not realize I could use this. Thanks! The calculator demo works perfect but I doubt if the Factory Test program is the one which was factory installed. I can upload it from M5Burner but it did no replace the previous installed sketch. Besides uploading is very fast so I suppose the filesize is too low to be the sketch I intend to upload.

  • The test program is available via M5Burner

  • Solved! With M5Burner I had downloaded the factory test .bin file and could upload it to the M5Paper. Unfortunately with a blank screen.

    It turned out that the downloaded .bin file on the hard disk was only 352 kb, much too small of course. I downloaded it again and the size was 2,137 kb by then. Then I flashed that file and everything now works as it should.

    Things would have been a little easier if M5Burner showed an error when a .bin file is corrupt or incomplete.

  • Have the same problem.
    Where to find the the factory_test.bin file?

    Thanks for any help.

  • @powersoft Hi, The factory test can be burned through the M5Burner software

  • @powersoft

    Found the bin file, under the M5 Burnet