UIFlow doesn't start on new Core2

  • hello Felix,

    just to be clear, when you run the Factory Test the screen in your M5Core2 works, correct? correct. here's a screenshot of the test running:

    ![alt text](0_1609747947765_IMG-2857 (Small).jpg image url)

    After burning UIFlow, have you tried to reset your M5Stack with the reset button?
    Also have you tried to fully shutdown your M5Stack by pressing and holding the power button, then power it on again?

    the device has been reset and turned off and on multiple times indeed.
    so weir, I reckon...

  • Hello @puzznic,

    I just received my first Core2 yesterday, and I had the same problem trying to run the uiFlow 1.7.1 firmware.

    After many attempts, I finally tried the 1.7.0 version, and it worked ! Maybe try this version instead of the latest one.

  • Hello @puzznic

    after burning UIFlow, what do you see in the COM Monitor log of M5Burner when you reset M5Core2? Any errors?


  • I'm running into the same issue. Right after

    "Hard resetting via RTS pin...

    Burn Successfully"

    The m5stack display freezes and in the console output is:

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    invalid header: 0x4f44213c
    ets Jul 29 2019 12:21:46

    on an infinite loop.

    Even after re-burning it with the easy loader when I attempt to burn UIFlow_Core2 the same issue occurs. Any advice is greatly appreciated.

  • Hi guys

    @NetworkUke : please see your other post. In your case the firmware file size is way to small.

    @puzznic : have you tried to reduce the baudrate? Not sure that will help but worth a try.


  • It seems to be the same situation as the Core 2 I bought yesterday.
    Core2FactoryTest and draw_by_touch work fine, but UIFlow_Core2 v1.7.1.1-core2 (I also tried v1.7.0 / v1.7.1) doesn't work.

    However, it seems running with black screen. I tried connect to Core2 from UIFlow Cloud and run the program. print() can print text to the serial console, but M5Label will show nothing on the Core2 screen. just black screen.

    I tried burn with low baudrate (115200), but nothing changed

  • Since UIFlow display nothing on the screen, I tried the test with the ILI9341 library for MicroPython I found.

    I copied the above library to Core2 and ran the following code from the serial console.

    import ili934x
    from machine import Pin, SPI
    spi = SPI(miso=Pin(38), mosi=Pin(23, Pin.OUT), sck=Pin(18, Pin.OUT))
    display = ili934x.ILI9341(spi, cs=Pin(5), dc=Pin(15), rst=Pin(4))
    display.fill(ili934x.color565(0xff, 0x11, 0x22))
    display.pixel(120, 160, 0)
    display.print('1234567890 ABCDEFGHIJKLMNOPQRSTUVWXYZ')
         :     :     :
    display.print('1234567890 ABCDEFGHIJKLMNOPQRSTUVWXYZ')

    As a result, the characters are displayed as shown in the image below.
    I'm not sure what this means, but can it help analyze the problem?


  • I had the same problem.
    Core2 did not turn on after
    Currently I am using 1.7.0 instead.

  • I don't know what happened. Core2 that has not been displayed with UIFlow for 2 days since I bought it, suddenly, yes suddenly, when I reset Core2, something was displayed, and every time I reset it, the display was distorted or displayed upside down. After several resets, the display is now showing normally.

    I feel that there is an unstable part in the display-related HW. Firmware is UIFlow_Core2-v1.7.1.1-core2.bin.


  • It seems that it was a short-lived joy. Revert to a black screen, distorted screen, or an upside-down screen.
    I tried v1.7.1.1, v1.7.1, v1.7.0, v1.6.6 and they are all the same and have a black screen.
    It's HW problem?

    0_1611197748884_IMG_5968.jpeg 0_1611195351484_IMG_5964.jpeg 0_1611195361024_IMG_5965.jpeg 0_1611195373828_IMG_5966.png

    Also, even in this situation with UIFlow is running, if I burn factory test firmware, it will work normally.


  • After struggling for a while, I had this Core2 replaced at the shop where I bought it as an initial defect.
    I'm not sure, but it seems that the display mechanism in Arduino and the display mechanism in UIFlow are different, and even if Factory Test works normally, it may not work properly in UIFlow.