WIFI connection failed (partially solved)

  • Hello all, I'm new here, and have been trying to get the basics going. Couldn't get my Atom Matrix connected to wifi. I'm using Unifi products from Ubiquiti by the way, multiple APs with WPA personal etc. Typical setup.

    I put my SSID and pwd into the burner software and it would not connect. I put the device in AP mode and connected with my phone and entered the SSID pwd that way, also failed to connect.

    I searched the forum and saw a variety of issues, including, especially that esp based things can't connect to SSIDs with spaces so I tried both of the above using %20 instead of spaces, but that also didn't work.

    I created a new network with no spaces and tried to connect to that one using both of the above methods and, again, fail...

    So, then, in UIflow, I just put a wifi connect block into my "sketch"/"M5" (?) after the setup block and lo and behold it connected.

    I'm not sure why the block can connect while other methods cannot, but anyway this will work for me because I plan to use this device in deep sleep, waking on button press and sending a REST call to open my wifi garage door either directly to a Shelly1 which is controlling the door or to HomeAssistant that is controlling the Shelly1. Haven't done any of the latter steps but thought others might appreciate what worked for me so far.

    If anyone knows why the wifi connection won't work otherwise, I would love to hear as I plan to buy a few more of these cool devices and some will likely be always powered and would benefit from connecting to wifi outside of the sketch.