M5 Stack Core 2 AWS bricked and my experiences

  • I have an M5 Stack Core 2 with AWS.
    Following the intro screen, I tried the AWS demo programs - way too complex for a newbie, but they worked. Eventually from google, I found you need to install M5Burner and that helped a lot. I think the AWS demo should give some info about using UIFlow, Burner etc

    So then I tried UIFlow_Core2 and after uploading a couple of sketches I found I couldn't turn my Core2 back on. Bricked?

    Eventually I read a post about hearing the PC beep when disconnecting the Core2 Usb cable, which I had noticed. So I found installing the Burner app a couple of times with the Core2FactoryTest program eventually resolved my Bricked core issue. And then everything starts perfectly again - phew.

    I'm finding that I need to switch between the Burner install of UIFlow_Core2 Configuration and exiting and restarting UIFlow when I want to install a new UIFlow sketch version. Is this normal?

    Overall I'm happy with the Core2 but I must say with the bricking issue I nearly sent the thing back to the supplier in the US, and the UIFlow/Burner switching issues are a pain.

    I hope the installing of Burner helps other people resolve their problems too. Anyone else having similar issues?

  • No thats not normal. are you sure you have the battery fully charged?
    Normally you only run M5Burner to install new versions of UIFlow or to install the AWS demo.
    You shouldn't need to install new firmware everytime you install a program in UIFLOW web
    I confess mine is actually sat in the inbox waiting for me to start work on it once I finish documenting the E-ink models.

  • I met just the same issues at the begining of use my Core2, but later I figured out that its just a problem of M5Burner and M5Stack project immaturity. Only UIFlow and Core2 factory test apps are compiled properly for Core2, other programs listed in M5Burner compiled for M5Stack Core and incompatible with Core2 (you can recompile they using sources and proper includes). Anyway after "bricking" the Core2 you can easly burn UIFlow or FactoryTest or another manualy compiled program through M5Burner or PlatformIO or standart ESP-IDF toolset from Espressif. Its not a real brick state, but just firmware incompatibility.