Core 2 Arduino getting started

  • Trying to get started with Arduino 1.8.15 (Win10 PC) and Core 2, following this guide...

    Should be simple. But an error occurs during step 7, installing M5Core2 in Library Manager.

    There is a list of 15 dependencies (M5GFX,UNIT_ENV,UNIT_4RELAY,Adafruit MCP4725,Adafruit TCS34725,Adafruit NeoPixel,Adafruit MCP4725,MAX30100lib,MFRC522_I2C,M5_BM8563,M5_ADS1100,M5_ADS1115,HX711 Arduino Library,PCA9554), I choose the option to install all, but a "No protocol:" error pops up in red after installing the first 10 and installation seems incomplete. Afterward I can search and see that MFRC522_I2C and onward were not installed even though Library Manager now says M5Core2 is installed. I have un-installed / re-installed Arduino several times (each time deleting Arduino and AppData\Local\Arduino15 folders as well) but each time I run into the same problem in the same place.

    Installing the remaining libraries manually doesn't seem to help, if incorrectly installed libraries is in fact the problem, as sketches fail to build (helloworld in this case, but all example sketches give the following error):
    ..\Arduino\libraries\M5Core2\src/M5Display.h:117:12: error: 'vector' in namespace 'std' does not name a template type

    Any suggestions? Thanks.

  • Work around found:

    • Fresh/clean install of Arduino
    • Install M5Core2 in Library Manager & opt to include all 15 dependencies (will fail with "no protocol:" error)
    • Install manually the 5 remaining dependencies that failed (MFRC522_I2C,M5_BM8563,M5_ADS1100,M5_ADS1115,HX711 Arduino Library,PCA9554)
    • Install M5Core2 v0.0.1 in Library Manager (downgrade)
    • Update M5Core2 in Library Manager to latest version (0.0.6), will list 0 dependencies and ask if you would like to install them, but select "Install 'M5Core2' only".

    Can now compile and run helloworld example (and others too). Confirmed same install problems encountered on a second PC, and same work around solved it.

    Arrgh~! Shouldn't be this messy/difficult.