Core 2 Device and UIFlow updates using Wifi with a running app?

  • I'm new to M5Stack development and facing an issue with the UIFlow code upload into my M5stack Core2 device. When doing a fresh firmware burn from "M5 Burner", I'm able to watch a successful (green) connection with the server. Once the main application is loaded, then I’m not able anymore to synchronize the Core2 device using Wifi. I’ve tried several procedures like pressing the "C" button but the device is not returning into a network setup mode. Indeed the application starts too quickly to get into the network menu. I’ve validated the APIkey, its OK. Any help how to connect the UIFlow server in order to upload latest application updates, without need of loading a fresh firmware at every update?

  • Hello @falbriard

    yes, after a Download the M5Core2 automatically switches from Internet mode to App mode and as long as it is in this mode it doesn't connect to the UIFlow server anymore, but runs the downloaded program. Try using Run from UIFlow instead. This should temporarily download and run your program, but stay connected to UIFlow server. Then only when you're happy and want to permanently install your program use Download.

    To go back to Internet mode on M5Core2 is a pain, I agree. Next to the (too) short time the menu shows I suspect that the active touch areas are too small and therefore hard to hit properly.

    As an alternative to switch modes, have you tried the Configuration button in M5Burner? It should allow you to switch back to Internet mode as well (w/o the need to redownload UIFlow firmware).


  • @felmue Thanks for the detailed instructions. Now able to handle it.