M5 Stamp Pico boot loop

  • I've made a mistake with my latest update and I have a M5 Stamp-Pico stuck in a boot loop. There's no reset or boot button on either this board or the M5Stick Downloader board, and I can't find any documentation on the process.

    How do I get this board to boot in upload mode so I can re-flash the firmware?


  • Solved:

    Connect a wire between GPIO0 and GND, then with that wire in place, connect the USB program board as normal and power on. It will boot in download mode and you can re-flash the firmware.

  • Well, I'm not sure whether the post I found about shorting GPIO0 and GND is a good idea on this board. It allowed me to re-flash the firmware once, but now I can't open a serial connection to any boards. I think it fried the USB download board. :-/

    Does anybody know a proper way to use the M5stack USB Downloader board and force a M5 Stamp Pico into download mode on boot?

  • @myxiplx the official downloader shorts en and G0 momentarily to get the stamp into programming mode. With the drivers causing problems the serial terminal can be a pain. What software are you using for the terminal?

  • Nevermind, problem solved.

    After troubleshooting this with Visual Studio Code and Putty, on various USB ports, with the USB Downloader board and an ESP-Prog board, and even rebooting my computer to check driver issues...

    ... it turns out I have a bad pin on the breadboard that I've been using to test these. It somehow failed after the last firmware update, direct connections to any of my boards works just fine.

  • @myxiplx Glad you found the issue.
    I have noticed that the pico header pins get worn out quick when just using headers in and out of the PCB.