M5Stack GPS module (M003) finds no satellites

  • Hello,

    I have bought two M5Stack GPS modules. Finally I only want to use the PPS signals, but even with the external antenna the PPS output (directly at pin 3 of the NEO-M8N chip) does not work. When I connect the module to Core 2 I am able to communicate (through port 14/13) with the modules, but it is not able to find any satellite. For the test I used UIFlow V1.8.8-core2 and an Arduino sample of the support. I could also verify the communication as it switches to INVALID for the satellites without GPS module connected to Core2. For the test I used the internal and the external antenna (of course I changed the internal connection each time), also outside the building with free view on sky. Has anyone of you an idea, why it does not work? It would be quite strange having received two defect modules by a well-known European distributor.

    Thanks, Dennis

  • Hello @dennis78ac

    I wonder if maybe there is a power issue?

    There is another GPS module (COMX.GPS / M031-G) and for that module M5Stack engineers suggest to use external DC power if used with M5Core2.

    When used with Core2 series main control, due to the different order of the base pin array, COM.X base pins TX(16), RX(17) correspond to the actual pins TX(14), RX of the Core2 main control (13) The equipment needs to use external DC for power supply.

    Note: When using the CORE2 or CORE2-FOR-AWS main control to drive the module, please use the DC power input of the base and set the power mode to input mode (refer to the code below), otherwise it will not start normally

    Do you happen to have an M5Stack (Base, Gray, Go)? If yes, does the GPS module work with it?


  • Hello @felmue

    thank you for your ideas. Nevertheless the M003 module only needs 3.3 V, as both chips (NEO-M8N and M24C32) are working with 3.3 V. Nevertheless I enabled also the internal 5-V-bus and I verified at the bus with a multimeter that both voltages are present (see also schematic https://docs.m5stack.com/en/module/gps#schematic) ... and even if I switch to external power supply with the help of LAN module W5500 I have the same result. Unfortunetely I have only the Core2 base and not another core for testing.

    Greetings, Dennis

  • I have tried quite a lot of things, but the M003 modules did not find any satellites. At least the PPS pulses should be present even without any core connected if the modules are powered with 3.3V. Probably I received two defect devices.

    Meanwhile I bought two GPS units of type AT6558. They are less expensive and they do now their job without any problem. They have even the advantage of an integrated voltage regulator, so they are not dependant of a power supply with an exactly regulated voltage value.

    It is just a little bit tricky if one wants to use the pps output of the GPS chip as it is already connected with a blue LED inside the device (not visible if case is closed). So some soldering work has to be done.

  • Hi the solution is Turning of the PSRAM in tools in the arduino IDE.
    Also you need to go outside for signal.
    If you have "no gps connection" try to switch the tx and rx pin in the ss.begin()