UnitCam with Core2

  • Hello everyone,
    Can anyone please advise if the UnitCam can be used with the M5Stack Core2?
    The Cam Unit is greyed out in UiFlow.
    If the UnitCam can be used with the Core2 I presume it needs to be wired to the pins beneath the CORE2 cover on the rear of the M5Stack Core2.
    Any help greatly appreciated.

  • Hello Everyone,

    I am facing the same issue. The CAM unit is greyed out in UIFlow for Core2.
    How to get the live video of Unitcam on Core2?

    Also the CAM2CORE sketch (https://github.com/m5stack/M5-ProductExampleCodes/blob/master/Unit/UNIT_CAM/CAM2CORE/CAM2CORE.ino) does not work for Core2. If this sketch is uploaded to Core2, the Core2 does not boot any more.

    Any help on this is greatly appreciated. Thanks

  • I can confirm that the UnitCam does NOT work with UIFlow 1.9.8 on a Core2.
    It does not seem to be supported.
    A UnitCam stream works without a problem connected to PortB with UIFlow 1.9.8 on an original Core. I have not properly tested the cloud functionality - it didn't seem to work for me. QR code for the url was never displayed.
    There must be some technical reason why the UnitCam stream doesn't work on a Core2. Different UART behaviour?
    However there is NO warning on the UnitCam store and doc pages that it currently does not work in UIFlow 1.9.8 on a Core2. If you only have a Core2 I don't think it will work. Luckily I have both Core2 and origjnal Cores so I could get it working.
    Has anyone successfully tried a UnitCam on a Core2 with Arduino instead of UIFlow?

  • @veryalien said in UnitCam with Core2:


    CAM2CORE not working? #41

    Unit CAM
    Camera UART to Core / This program is suitable for M5Core, used to receive images from UNIT CAM via UART, please do not burn to UNIT CAM

  • Confirmed, the UnitCam does NOT work at all on the Core2 in UIFlow or Arduino.
    The Arduino UART to Core does NOT work on the Core2 - it does not boot.
    I managed to fix this problem!
    I will just use my UnitCam on my Cores and wait until it gets fixed for the UIFlow Core2 - if ever.

  • I fixed the problem with the cam2core on the core2. So the UnitCam will work with Arduino IDE code and the core2.

    It is a very simple fix:
    Replace the first line #include <M5Stack.h>
    with #include <M5Core2.h>

    Initialising the core code on a Core2 is not the best idea!
    Now it works on my Core2 showing the video stream from a UnitCam connected to PortB (pins 26, 36).

  • This post is deleted!