UIFlow + StepMotor Driver M039



  • Hi,
    I'm using a M5 Core1 with UIFlow 1.9.0, installed with M5 burner on MacOsX 12.

    I use the StepMotor Driver module M039 with UIFlow.

    0_1642371381204_Image 036.jpg

    The fonctions provided by UIFlow are :
    0_1642371443010_Image 038.jpg

    2 bugs here I think :

    • fonction "Set step motor pulse freq" could not be set to 0 (which is sadly the default value provided). If you set freq to 0, next blocks are not executed and with no error which makes it very difficult to debug.
      0_1642372198894_Image 039.jpg
    • fonction "Set single motor state" could be set to X, Y or Z to control each motor individualy (I hope). But it doesn't. The motors are all working together. It is exactly as if you used "set all motor state".
      0_1642371776165_Image 040.jpg

    To control each motor individualy, I need to use the pwm functions but I cannot control the Z motor like this because there is on 2 timers (0 & 3) available.
    0_1642371986496_Image 041.jpg

    Could you please correct the "Set single motor state" function ?

    Thank you



  • A little update : UIFlow has been updated. The state and direction are not usable the same way :
    0_1649091005329_Capture d’écran 2022-04-04 à 18.47.44.png. That change broke our program (it's a pitty). Now you can use variables, you need to make 'ifs' because direction is now forward/reverse et state is now pause/resume.

    At the same time, bugs are still there : you cannot command a single motor, even if you use "set single motor X state resume", it will start the 3 motors at the same time. You must use the workaround I talked about in my previous post : pwm.