uiflow online unable to open recently saved files (Core 1.9.5)

  • Have M5 Core, firmware 1.9.5, using UIflow beta online, with blockly coding (Edge and Safari browser). After editing file and downloading (uploading) to device I save it to desktop. Then I am unable to open it again, making it impossible to continue work :(

    How to fix this, to be able to continue coding?

  • @cortado This is odd because I have been opening/ editing and closing files with no problem but im using chrome.

    This could be an issue with safari and chrome not working correct (which is known issue with edge and safari)

  • @ajb2k3 I have tried Chrome on Windows PC, same result...

  • @cortado Code works fine in M5Core, but now I can neither load that code back from Core, or upload downloaded m5f file. Please advice

  • Is this caused by a problem with the Python code generated by WEB IDE?

    I am ble to open the file in UIflow desktop IDE (1.7.4) , but it defaults to Python tab. WHen I switch to Blockly iut stated Blockly will not support generated python, but everything seems ok in Blocly and I can save the file with new name, AND THEN OPEN IN WEB IDE (1.9.5)

  • Did you manually alter the code in python view, if so then you can’t switch back to blocky view

  • @cortado I have a similar problem with M5Stack Tough. Its basically impossible to read files just saved to PC or open old files. This have been working fine a week ago. Tested with new version of desktop IDE and Web. Frustrating......

    It seems like it loads the python code, but not showing any uiflow graphics.

    I understand the desktop IDE is discontinoued. This forces me to use WIFI. This makes it impossible to use at work with the network policy there. Is it possible to use web-ide and USB cable?


  • @janulr As far as I'm aware, Web USB is not fully supported by all browsers and so not configured.
    Have you contacted your web administrator and told them you need the server access ?

  • @ajb2k3 The main problem is that recently saved UIflow programs are not possible to be loaded again.
    Have tried with both web and desktop versions. I believe this is related to custom modules.
    Basically wasted 4 days on this and had to rewrite the program over and over again.

    I doubt my employer will change IT policy for me testing the M5Stack modules. Please reconsider the strategy of discontinouing the desktop version. To use the web version is a hassle and as soon as a program is downloaded (not just run), i have to go through the process of setting up the m5stack wifi again. I guess i have to drop UIflow and go back to Arduino IDE. (Sad, as UIflow is a good selling point for using these modules in education of kids)

  • Ahh custom modules, that explains it!
    I just check 1.9.6 web and it loads all my old programs.
    Yes, if you have a custom module then UIFlow will crash (for want of a better name) because it can't find a matching module.
    I am running a 2012 MacBook Pro and an Raspberry pi4 and with internet access I can use UIFLOW web but when the internet is unavailable I use an open source IDE called Thonny which allows my to program in MicroPython and use the core REPL interface over USB.

    There is a new M5Pi coming and I have been pushing to get a stand alone UIFlow server set up on it because of your issues but also for schools who want to run on an isolated secure network that is separate from the main site network.

  • @ajb2k3 said in uiflow online unable to open recently saved files (Core 1.9.5):


    Thank you, ajb2k3.
    So if I need to include a custom block, it cant be used in M5flow? The strange thing is that the custom block works - I just cant upload the UI flow program after it was saved.

    I need a simple way to get a 1-wire temperature sensor (DS18B20) connected and later implement a simple PID temperature control. Any suggestions of how i interface with DS18B20 using M5flow? I really hope I can keep working with M5flow as this makes programming much easier for kids.

  • @janulr I have found the same issue - unable to open M5F files after saving and closing. But looking at the clues above I found a workaround.
    I have a custom block for DS18B20 in the original file. If I add the custom block back in to UIFlow again and then open the file IT WORKS. Otherwise I get a blank Blockly screen and most of the pyton code is missing, Display screen is also blank. Hope this helps.
    Developers need to find a way of warning when the M5F is opened that a "Custom Block is Missing". That way we can load the block and continue.