Cat-M1, and Cat-M1+GNSS breaks core/atom

  • Whenever I plug a Cat-M1 module (Including Cat-M1+GNSS) into a core it refuses to turn on even when plugged in, and when I plugged it into an AtomU the computer the AtomU was plugged into momentarily showed a blank screen and didn’t accept input, in a StickC-Plus it worked fine on startup but anytime I ran a program, It just showed a blank screen. I’m not sure if this is a power draw issue, user error, bad manufacturing (but I wouldn’t expect that from M5), or something else.

  • Hello @HWTaro9

    I don't have the Cat-M1+GNSS module so I cannot test myself. But yes, what you are describing with the various M5Stack cores sounds either like a power draw issue or a defective module.

    Have you tried to power the Cat-M1+GNSS module with its own power supply instead of relying on whatever the USB port can deliver?


  • @felmue plugging it into a 12VDC 3A power supply makes it work fine on all of my devices, so it was just power draw issue.