Arduino Board Manager - Download Slow/Fails

  • Re: Downloading updates - fails

    Hello, I've been trying to download and install the M5STack package from the Arduino IDE but it keeps failing. It downloads some very slowly and then fails.

    The website speed on docs and store is also very slow. This previous post from 2 years ago references your regional CDN. Is there a problem there? The forum also keeps telling me that connection has been lost...

    Please could you check everything is ok from your end please? I'm based in Berlin Germany.


  • Hello @slepwalker-dev

    yes, website speed is slow at times for me too. (I am based in Switzerland).

    Regarding download:

    • Have you tried from a different computer?
    • Have you tried to download the package outside Arduino IDE first?
    • Could it be the virus scanner on your computer is interfering?


  • Hello, @felmue

    Thanks for your reply. I have tried with 2 different computers from 2 different internet connections. I am able to download packages from GitHub directly, but I'm not sure if there are the correct packages as the file sizes differ.

    Anyway, I ended up changing my approach for the project I'm working on, (using Pololu direct to Arduino) so I'll try M5Stack another time.

    Thanks anyway.

  • China has issues at present and so that is effecting the speed of the M5Stack site which is hosted behind the Great Firewall of China.