Atom lite does not work with OTA

  • I'm trying to update my home devices (atom lites) using OTA. However the simplest OTA examples do not work. All first it seems to work fine. The webserver can be reached, a .bin can be selected but it fails somewhere in the early phase of uploading to the device with the following error: abort() was called at PC 0x40081f82 on core 1. I also tried another OTA library; the ElegantOTA with the same problem. Anyone any experience with this? And perhaps a solution?

  • Hello @Kees

    have you tried with a different browser and/or OS?

    For me both OTA libraries ArduinoOTA and ElegantOTA work just fine using the provided examples.


  • Hi Felix,

    Thank you very much. I did not expect this, but indeed the problem is the browser. I use Firefox as default browser (on Windows 11). I switched to MIcrosoft Edge for this and it works.
    Any idea what the reason is? I presume some extra bytes transferred, but why. Or/and is it about the way the webserver handles it?

    It took me quite some time and could take me much more time without your solution!

    Thanks again,

  • @kees No, its to do with the fact that not all browsers are written the same. for best results always use google chrome as its the most upto date with web development standards.