Micropython for Atom S3 Lite

  • Can somebody point me to the correct firmware to run Python on Atom S3 Lite?

    thanks in advance,


  • There should be a UIFlow (Micropython) for the s3 lite in M5Burner or a generic s3 port of Micropython on the Micropython web site

  • Thanks for the reply: the firmware that works is the Atom S3 UiFlow.
    Strangely I can connect using upycraft but not with thonny.

  • I initially also had big problems connecting with Thonny
    After changing the "submit_mode" to "raw" in the ESP32 section of the config file it worked:

    port = COM10
    interrupt_on_connect = True
    sync_time = False
    local_rtc = False
    restart_interpreter_before_run = False
    submit_mode = raw

    for further details: https://github.com/thonny/thonny/wiki/MicroPython see the chapter Advanced configuration

  • @marcod Check your settings but you need to hold the button down first before connecting the USB lead to use Thonny but also play with the micropython setting as some controllers use Generic, some Use MPesp32 version

  • Hi Marco,

    To run Python on the Atom S3 Lite, you'll need the correct firmware for your device. It's important to ensure that you download the appropriate firmware version that matches your device model.

    To locate the correct firmware, I suggest checking out the official Atom S3 Lite website or contacting their customer support team for assistance.

    They will be able to provide you with the exact firmware that you need to run Python on your device.

    I hope this helps!

  • I was able to flash my S3 Atom Lite using the file M5STACK_ATOM-20230426-v1.20.0.bin from this location https://micropython.org/download/GENERIC_S3/
    I have not tried to use thonny with it but I can connect via the serial port and execute Python statements.

  • 0_1684991309409_Screenshot 2023-05-25 at 06.07.54.png

    Please only use the Version found in M5 Burner as I will have the drivers for units pr included whereas Mainstream MP will not have the necessary changes and libraries added to support units.

  • @ajb2k3

    • actual M5Stack version in M5 Burner, which is alpha, is based on MicroPython 1.19...
    • Latest version on Git, which include lot of improvements, is 1.20

    Is it scheduled before the end of alpha releasing to have an M5Stack version based on 1.20?

  • @flex I don't know I haven't spoken to the DEV at M5STACK and don't know the development route.

  • @ajb2k3 OK, I will try using M5Burner. I have an Atom Lite, so should I select "ATOM" in the list of devices on the left? And then should I select "Micropython" from the list on the right? I only want micropython, not UIFlow (at this stage).

  • @forestial For the Atom S3 lite, no use the Atom S3 UIFLow firmware.

  • @ajb2k3 On more careful inspection I see that my module is just ATOM LITE, not ATOM S3 LITE. So I have selected "ATOM" in M5Burner and then re-burned with "UIFlow_Lite" v1.11.8. However this does not appear to boot successfully, I cannot get to the >>> python prompt.

    Can you comment on what is going on? Am I using the wrong firmware for an ATOM LITE? (I can revert to the ATOM S3 version, which was working fine, but I am trying to learn how to do this properly.)

  • Have you followed all the instructions including setting the the correct inter-erasure and port?
    What shell program are you using?

  • I am burning with M5Burner, and using any of Thonny, PuTTY or python -m serial to connect afterwards. All of them fail. Sometimes I get a stream of "flash read error" messages; sometimes I just an ascii-art logo printed but then no response to the keyboard.

    I don't know about inter-erasure: can you point me to docs about that? At one point I did a "python -m esptool --port COM7 --chip ESP32 erase_flash" before re-burning, but without success. As noted, the burn process always ends successfully but after connection is when the trouble starts. I'm beginning to wonder if my Atom Lite is bad, but it was working before.
    (I said above that I could revert to the Atom S3 version, but in fact it is not working now either)

  • Adding to my own comment here: I believe my problems were caused by setting the 'Start Mode' parameter incorrectly. When I reverted it to "App Mode" the ATOM LITE seems to respond normally to the terminal (including Thonny) and I get the >>> prompt.
    I'm not clear what the other App Mode values are for, but for now it seems to be doing what I need.

  • inter-erasure? I don't know what autocorrect did to my comment, sorry!

    The S3 does NOT work like previous generation devices and you have to put it into "Boot Loader" mode by holding in a button before a serial connection can be open to use the REPL terminal.