M5paper no longer works with Arduino from new installs

  • Hi

    Why is it so complicated to set up the development environement for the m5paper?

    The only reliable environment is the UIflow, which works consistently. but seems a bit limited.

    The other other environments I've tried are Arduino - painfully slow (even with output disabled), and after compiling it doesnt reset the m5paper to run the code. I assume a later library or something has broken it?

    ditto for VScode and Moddable

    The "Hard resetting via RTS" doesn't reset it.
    Python 3.11 seems to have broken it

    Maybe I'm being a bit impatient, but I dont want to have weeks configuring/fixing broken development environment(s), I want to learn how code for the m5paper.

    => Which is stable and doesn't take ages to compile programs, and is compatible with m5paper?

    Maybe my expectations were a bit high, but it does seem to be new user hostile!
    Maybe I should stick with the UIflow.


  • I am with you.
    I try to get something usefull out my m5coreInk but there is no help/support/documentation out there at all.

  • I tried to teach a YouTuber Arduino core the AtomS3 and I hate Arduino it is a monster pain to use and so many libraries have to be installed just to do anything.

    Also Ink/papers are complicated because they work fundamentally differently to tft/LCD OLED displays.

  • @ajb2k3 thanx for your afford, but that makes no sense. functionality will be same and just needs to be adjusted to the display. we all know that e-ink is different than lcd, so its no help pointing that out.