U128 CATM @ Atom Lite and AtmoS3 Lite @ UiFlow v1 and v2

  • Hi, I'm trying to run a project that can control a relay using LTE-M communication.
    I'm working with the CATM (U128)

    I'm using two different modules: Atom Lite and AtomS3 Lite, so in UiFlow v1 and UiFlow v2. While UiFlow1 has an additional CATM UNIT, UiFlow2 does not.

    In M5Burner, I've set com.x to True and set the APN as required for my SIM card.
    Does anyone have a ready-to-use project built with blocks using MQTT? Either for UiFlow 1 or 2. Because I can't get it to work.

    While I've built a program on Wi-Fi that sends and receives MQTT, with the CATM I don't receive any IP as if it's not connecting to the internet.

    On the module's page, there's only an example for Arduino and I'm looking for one for UiFlow.
    Below, I've attached a screenshot of the blocks and while I can retrieve IMEI or CCID queries, I'm unable to connect to the internet.

    The SIM card is tested on Mikrotik KNOT, where I also have LTE-M and I can send and receive MQTT there. The PIN is turned off.

    I'd greatly appreciate any support on what and how I can check why I'm not getting an IP address. Thanks.

    0_1692607485678_Screenshot 2023-08-21 at 10.40.40.png

  • Hello @marek-5pi-eu

    I think the COM.X flag and APN field in M5Burner only works for COM.X modules (and not for units) as setting that flag to True or False doesn't change anything in my tests.

    What is the blinking pattern of the blue netlight LED? It tells you about the connection / registration status.

    From the Hardware Design document:

    NETLIGHT pin status Module status
    64ms ON, 800ms OFF --> No registered network
    64ms ON, 3000ms OFF --> Registered network (PS domain registration success)
    64ms ON, 300ms OFF --> Data transmit (PPP dial-up state and use of data services such as internal
    OFF --> Power off or PSM mode

    BTW: the modem should get the correct APN from the network automatically.


  • @felmue Hello Felix,

    Thank you very much for your response. Do you have any sample working code for UiFlow with CATM?

    The mentioned blue light blinks every 800ms, indicating no network connection. I tried the SIM card again on Mikrotik KNOT, and it works there. Hence, I assume that the SIM card is fine.

    Maybe the Polish provider Orange doesn't automatically assign the APN. How can I configure the APN using AT commands?

    Thank you.

  • Hello @marek-5pi-eu

    no, I do not, sorry.

    Have you tried the pass through example so you can try and test AT commands from a terminal? You'll need to adapt UART2: TX = 26, RX = 32.

    You can find the necessary AT commands to manually set the APN in chapter 4.2 of this document.


  • Hello Felix,

    Thank you very much for your assistance. After manually configuring the APN via AT commands, everything is working perfectly. The pass-through example with UART2: TX = 26, RX = 32 was very helpful.

    Thanks again,
    0_1692747037472_Screenshot 2023-08-23 at 01.29.03.png

  • Hello @marek-5pi-eu

    you are welcome. I am happy to hear you got it working. And thank you for letting me know.