Core2 and VMeter

  • Hi,

    I have an issue with the provided examples regarding the Core2 and the VMeter.

    I have tried all the examples I can find on the M5Stack Github but each have the same result, The Touch Screen stops responding to touch after programming and boot.

    I have confirmed that the Touch Screen still works correctly. By reprogramming the factory default sketch back into my Core2 and that functions correctly.

    What I am doing wrong?
    What I am overlooking?

    Any help will be much appreciated.

    Kind Regards

  • Hello @PaulB

    have you also tried the example linked from the VMeter documents page?

    Note: Unfortunately I do not have the VMeter unit so I cannot test it myself.


  • Hi,

    Thank you for the guidance, I now have it "working" but had to change quite a bit of code.

    The Core2 download "pack" that I initially installed has completely different example code as well as the M5_AD1115 library has a few typo's in it so the examples don't compile to start.

    I now know not to trust the initial download "pack" and over write the separate library's with the library's for the separate GitHub library's, then check for Typo's.

    M5Stack should review every download "pack" to make sure all their examples work out the box, to avoid confusion.

    Now I have working code, all I wanted was to have a simple Volt Meter that I can build into a Test Fixture and read voltage back to a C# GUI, now the code from your links only shows a negative voltage, the only way to correct this is to swap the positive and negative connection points to my circuit I am wanting to measure.

    It's not ideal, but at least I have a working solution, Thank you again.