Cardputer COM Not Working

  • Hello. I just bought a Cardputer (M5 Stack v0.9) and I'm trying to change the firmware to a custom version. I'm using Windows 11 (22631.3085) with M5Burner-v3-beta-win-x64. Just for the record, have Python 3.11.4.

    I want to install the "Nemo" firmware ( I am aware that it is an unofficial version) and I am following the following steps on the documentation:

    1. Installed FTDI drivers;
    2. Downloaded M5 Burner
    3. Downloaded Nemo 2.3.3 inside M5 Burner
    4. M5 Burner finds COM3.
    5. When trying to burn, I get stuck connecting to the device and get the following error:

    --chip auto --port COM3 --baud 115200 --before default_reset write_flash -z --flash_mode dio --flash_freq 80m --flash_size detect 0x000 C:\Users\User\Downloads\M5Burner-v3-beta-win-x64\packages\firmware\e7fcb8d6a9c59e5db631bfd5e9d77227.bin v4.6.2
    Serial port COM3
    A fatal error occurred: Failed to connect to Espressif device: No serial data received. For troubleshooting steps visit:

    1. I checked the troubleshooting page. The device is being powered via USB, I have tried all bauld rates available on the M5Burner. I tried using Arduino's IDE Serial Monitor to check the connection, but the device was not recognized. Error persists.

    Am I missing any details?
    Thanks in advance!

  • Hold bingo or BTNRST for 5 seconds to get it into bootloader mode while trying to connect

  • Hello, ajb2k3.

    Thank you for your help. Sorry if it's a simple question, I'm not very experienced in hardware. I tried both options, BTNRST and BTNGO, one at a time for five seconds, both together for the same time, the device starts normally. It also does not appear in the system's device management panel.

    Maybe it's a problem with my notebook? (I tried on all USB ports) How do I know that the device started in bootloader mode? Is it just an internal option or will it give signals on the interface such as not turning on the display, not playing sounds, etc?

  • A green LED will come on inside the card computer when in boot mode.

  • Hello guys

    the M5Cardputer doesn't have that hold button until green LED lights up mechanism. To put M5Cardputer into download mode use the method described here.

    If you want to enter download mode, press and hold the G0 button on StampS3 before turning it on, then release it after powering it on.


  • @felmue I beg to differ there as I just tested And holding BTNGo down while the card computer is turned off does actually put it in boot mode and turns a green light on in the top left corner.

  • How to get the cardputer (card computer into boot loader mode.

  • Thanks for the comentaries, guys.

    It's incredible that I spent hours researching and didn't see a single simple video like this haha thank you. However, see what happens in my case. Even if turned off, the device starts with the factory firmware as soon as the USB cable is connected. (Sorry for the blurry image)

  • @hanktttop Sorry, just recoded and uploaded it.
    The Cardputer MUST be turned OFF before connecting the USB cable to into boot loader mode.

  • @ajb2k3 Not complaining lol It helped a lot, thanks

  • @hanktttop Just updated my comment

  • @ajb2k3 It is OFF. However, it still starts the moment the cable is connected. Even with the switch turned off.

  • @hanktttop It takes a bit of practice but on a Mac it should appear as a USB Modem if timed properly. It is difficult to do.

  • Hello @ajb2k3

    my apologies - I only read the comment of the M5Cardputer documentation w/o trying it myself.


  • @ajb2k3 Nothing yet. Apparently it behaves as if it were connected to a charger, not a computer. I reinstalled all the drivers, restarted the machine, but it's still the same. And I don't know if it's normal behavior for it to turn on as soon as it's connected, even with the switch turned OFF.

  • Hello guys

    @ajb2k3 : hmm, I've just double-checked with my M5Cardputer following your video and the LED does not light up. Maybe it depends on what firmware it currently runs?

    @HankTTTop : yes, that is normal behaviour - at least my M5Cardputer does that as well - it starts up as soon as USB is connected - even when off. (It is my understanding that the ON/OFF switch is for the battery only.)

    BTW: have you tried a different USB cable?


  • @felmue I tried different USB ports, but now that you mention it, it could be the problem. I'm using a USB-C that came from a portable console, which doesn't allow data transfer over this connection.

    I'll see if I can get another one tomorrow when the local businesses are open. Thanks for the sugestion.

  • New cable, same error. In fact, I just tested it on Fedora 39 (fresh installed), I still haven't been able to put the device in download mode. Maybe I'm forgetting a drive, which makes the device "recognize" the computer as a charger. Still, I reinstalled them all again, with no result.

  • OK next step is to VERY Gently pull the Stamp form the card keyboard (the pins are tiny) then with it removed you need to open M5Burner (after a fresh reboot of the computer) hold the button down hidden under the label, connect a USB cable in and wait for the led to turn green. I'm just digging out my old windows computer to make a video.
    And M5Burner should report as a USB Modem.

  • @hanktttop said in Cardputer COM Not Working:

    New cable, same error. In fact, I just tested it on Fedora 39 (fresh installed), I still haven't been able to put the device in download mode. Maybe I'm forgetting a drive, which makes the device "recognize" the computer as a charger. Still, I reinstalled them all again, with no result.

    I have M5Dial with StampS3 at the back...had to remove sticker to see and feel when "boot" button is pressed and hold before usb is plugged in - its almost hard to sense way different from pressing reset button where you can hear click.
    With my Dial when say com13 was unresponsive then going in to boot mode made com12 to be available so in short words diff com for programming and different for boot mode - thats my experience with StampS3 from my M5Dial - i had it few times in some unresponsive mode.