[NEW] UIFlow-Desktop-IDE : Not able to connect to target via COM port / UIFLow-Browser unreliable /Not possible to finish Setup

  • I rolled back to UIFlow-v1.2.3 and somehow got the startup menu to change from internet to USB and this times it works, so PROBLEM TWO solved. The FIRST and THIRD problem i described in my first entry on this thread remain. Thank you for your attention. JC

  • @jcabad100 The Server can be a bit funny at times but its working for me outside of China (servers are inside china).
    Have you tried a different web browser? IE is not always a good browser, try firefox or chrome.

    Issue 3 is strange because its just a first run demo.
    When you power on the M5Stack, keep pressing the right hand button to get into setup.
    Again, 1.3b firmware in only for the beta UIFlow and is temperamental, we use it for testing before moving changes to the main branch.

  • @jcabad100 The IR can be tested with a cameraphone and an IR remote.

  • @ajb2k3 thank you for your reply. I also use Google Chrome. I rolled back to 1.2.3 in fact. At the moment i am working locally via USB/COM but i encounter other problem (reported separately). Thank you anyhow.

  • @ajb2k3 i will try your suggestion for the IR test. Buy you didn't tell me if the Setup should finish with a successful setup message or similar or will it always be a "Test loop"??

  • @jcabad100 Sorry, it will just loop but after its run once completely, power off and on and the demo shouldn't run again.

  • The last screen of the demo is the angle sensor.

  • @ajb2k3 ..."angle sensor" should be called "potenciometer" , haha...that worked also (provided all the peripherals where connected before the reset=cold plug-in....hot plug-in doesn't work)...thanks..

  • @ajb2k3 i retested the Setup after reset and in fact it does not show anymore that initial peripheral/functionality test ...and i am presented with the menu to e.g. change from internet to USB-COM....that was the reason i was surprised that menu appear....so at some point the Setup decided to change from that test mode to show the new menu...it is not easy to understand at the beginning...anyhow let's say the THIRD PROBLEM i originally reported it disappeared (after multiple initial setup test loop).....the only problem that it remains then from the original three of this thread is the FIRST PROBLEM i.e. UIFlow-Browser - server communication extremely unreliable. Thanks again for your patience.

  • No worries, I’m here to try to help. Beyond this we will have to wait for the China team to check.