[NEW] UIFlow-Desktop-IDE : Not able to connect to target via COM port / UIFLow-Browser unreliable /Not possible to finish Setup

  • Hello everyone, i am located in Shanghai/China; i am new here; i bought 7 sets of M5Stack and i received them today; i have a 64-bits Windows 10 host computer. So far i successfully installed the CP210xVCPInstaller_x64_v6.7.0.0 driver, the UIFlow-Desktop-IDE and the M5Burner. I upgraded the firmware using the M5Burner to UIFlow-v1.2.3 first and the to UIFlow-v1.3.0-Beta. I also manage to connect to Wifi and using the (not secure) website http://flow.m5stack.com/ using the API key i manage to sucessfully download one first test program. A) The FIRST PROBLEM i have is that the UIFLow-Browser (http://flow.m5stack.com/ ) is completely unreliable; i dont know if that is do to the fact that i am in China (i tried with and without VPN....with VPN does not work at all)....with totally unreliable i means it works in 1 out of 20 attempts or so (it gets disconnected). B) The SECOND PROBLEM i have is that the i dont manage at all to use the UIFlow-Desktop-IDE because the app is not able to communicate thru the COM port (COM6 in my case); the Windows Device Manager properly tells that the COM6 is available and map it to the "Silicon Labs CP210x USB to UART Bridge (COM6)"; it appears (not sure about that) that it connects for 1-2 seconds and then it shows "COM: COM6 [Disconnedted]". C) Actually i have a THIRD PROBLEM, when booting if i press SETUP i enter in a never ending loop which start with "Hello" and walked me thru the different tests , Speaker, Microphone ..etc...i already connected all peripherals and all seems to work properly (not sure about the IR module, the RGB module light with all three LEDs in white...)...but i can never "finish" the setup...i always come back to port mapping explanation....i understand that as if i didnt manage to test one of the peripherals correctly...is that the right explanation? how to finish the Setup?....or is that not a Setup but rather a Test loop?? I am sorry for so many questions in one. Please help! Best regards from Shanghai, JC

  • The server is next to you so should be fine, there are issues with certain web browsers causing issues. I’m using Crome as the others fail.
    Try a new usb sync lead as the leads do not always work. The CP driver is flaky at the best of times.
    1.3 is for testing only and very buggy, please use 1.2.3

  • Hi there...immediately after i wrote above entry i restarted the system and for some unexplained reason i was presented, for the first time, with the possibility to change from internet mode to USB mode (i guess that is new in UIFlow-v1.3.0-Beta)....then i was finally able to connect via USB with UIFlow-Desktop-IDE (UIFlow-v1.2.3 it is written)....i tried then to download a program that worked before but it didnt run on the target; the target shows an error message "...clear..not found..." or something similar....so i decided to reburn the older firmware version UIFlow-v1.2.3....and after that the SECOND PROBLEM persist.....not able to communicate via COM6....Question, should that initial setup option to change from internet to USB also appear with firmware UIFlow-v1.2.3?? Thank you again! JC

  • I rolled back to UIFlow-v1.2.3 and somehow got the startup menu to change from internet to USB and this times it works, so PROBLEM TWO solved. The FIRST and THIRD problem i described in my first entry on this thread remain. Thank you for your attention. JC

  • @jcabad100 The Server can be a bit funny at times but its working for me outside of China (servers are inside china).
    Have you tried a different web browser? IE is not always a good browser, try firefox or chrome.

    Issue 3 is strange because its just a first run demo.
    When you power on the M5Stack, keep pressing the right hand button to get into setup.
    Again, 1.3b firmware in only for the beta UIFlow and is temperamental, we use it for testing before moving changes to the main branch.

  • @jcabad100 The IR can be tested with a cameraphone and an IR remote.

  • @ajb2k3 thank you for your reply. I also use Google Chrome. I rolled back to 1.2.3 in fact. At the moment i am working locally via USB/COM but i encounter other problem (reported separately). Thank you anyhow.

  • @ajb2k3 i will try your suggestion for the IR test. Buy you didn't tell me if the Setup should finish with a successful setup message or similar or will it always be a "Test loop"??

  • @jcabad100 Sorry, it will just loop but after its run once completely, power off and on and the demo shouldn't run again.

  • The last screen of the demo is the angle sensor.

  • @ajb2k3 ..."angle sensor" should be called "potenciometer" , haha...that worked also (provided all the peripherals where connected before the reset=cold plug-in....hot plug-in doesn't work)...thanks..

  • @ajb2k3 i retested the Setup after reset and in fact it does not show anymore that initial peripheral/functionality test ...and i am presented with the menu to e.g. change from internet to USB-COM....that was the reason i was surprised that menu appear....so at some point the Setup decided to change from that test mode to show the new menu...it is not easy to understand at the beginning...anyhow let's say the THIRD PROBLEM i originally reported it disappeared (after multiple initial setup test loop).....the only problem that it remains then from the original three of this thread is the FIRST PROBLEM i.e. UIFlow-Browser - server communication extremely unreliable. Thanks again for your patience.

  • No worries, I’m here to try to help. Beyond this we will have to wait for the China team to check.