Simple fix when upload fails.



  • I tried the cap, here is a screen shot of whats the problem. The pc is seeing the port, it recognises the driver and is working.
    It is trying to upload, but times out I tried both baud rates neither works.![alt text](0_1515100345875_screen.jpg image url)



  • This post is deleted!


  • I tried reversing the cap, It still won't connect. It still has the same timeout problem. Changing baud rate doesn't help either.



  • This post is deleted!


  • I am using win7 and arduino ide 1.8.5. The board automatically selects the com port when plugged in . The port varies .
    I have the cap soldered onto dupont leads and have them plugged all the way in. I tried both polarity's

    I keep getting the "timed out waiting for packet header " error. for whatever reason it won't connect. I have no problems with the ports with various Arduino boards, ESP8266's and ESP32's



  • This post is deleted!


  • @stanszalSimple fix when upload fails. 中说:

    I am using win7 and arduino ide 1.8.5. The board automatically selects the com port when plugged in . The port varies .
    I have the cap soldered onto dupont leads and have them plugged all the way in. I tried both polarity's

    I keep getting the "timed out waiting for packet header " error. for whatever reason it won't connect. I have no problems with the ports with various Arduino boards, ESP8266's and ESP32's

    As a note, I am having the exact same problem. I'm using PlatformIO, but the esptool output is the same indicating the same underlying error.

    When I look at the Serial Monitor, it's booted and here is the output:

    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:2
    load:0x3fff0018,len:4
    load:0x3fff001c,len:812
    load:0x40078000,len:0
    load:0x40078000,len:11404
    entry 0x40078aa0
    user code done

    I recovered mine using the EspressIF ESP32 Download Tool following the M5 guide for loading their MicroPython / Cloud IDE firmware.

    I wanted to play around with their cloud IDE anyway, but you should be able to use the factory firmware (also on GitHub) or one of the ones in your Arduino compile cache that you know works.

    Edit: Forgot to mention, I did have to use a 10uf cap across the GND and RST pins as described earlier in the thread in order to get the EspressIf tool to be able to connect.



  • After much fiddling around I managed to connect to it. However it is unreliable. This thing is a big disapointment. It is obvious a lot of work went into this thing, but they should have put in a little more to get it to work right out of the box.

    You can get Various Arduinos, ESP8266's and ESP32's for much less and they just work.


  • M5Stack

    0_1515468486302_QQ图片20180109112446.jpg
    so sorry, pls try this.



  • try what? add a cap? what type and volts? where can I get 1 cap? how about I send this back and you fix it so it works?



  • ++



  • Here is how I see it, I already spent over $40.00 for this thing. Yes, I can spend another $3.50 and order some caps, wait 5 to 6 weeks for them to arrive and they may or may not solve the problem. If this is a known issue you should have included a cap with the device.

    I tried 3 caps, 2 electrolitica and a polyester one. the result is the same, you need to try to upload the sketch multiple times to maybe get it to work once.



  • JimiT and ElectroMagnus, thank you for your help



  • ++



  • Hey @Stanszal ... I just got one of these and had issues with getting the uploading working. I found that if I reset the device and got the timing right then it would work. You just reset it while the "...____" message is writing. I can't tell you when to do it specifically, you just have to guess.



  • Mine worked great until today. I really don't understand why it stopped working today.



  • Hi guys, just got mine in today and it kept resetting while trying to program. Started at the forums and found this post.
    As a R&D engineer let me first just say the guys at m5Stack know what they are doing on the hardware side. It's an exceptions build, But looking at the schematic, i am kinda shocked they dont have a cap on the reset line.

    I tried 3 values and all worked. 0.1uf, 2.2uf & 10uf. Would not go higher than 10uf though.

    I stuck a 0.1uf cap on the reset pin to gnd, and mine works just fine now, Typically in this circuit anything =<10uf should work just fine.
    In the photo I put a 0805 cap, there. It would be best to stick a 0603 there but I didn't have any.
    You can get these locally at mouser or digikey.
    0.1uf cap at Mouser

    For those of you who dont have solder skills like this you can use a through hole cap like this one externally on the box from "RST" to "G". polarity does not matter for this ceramic cap.
    0.1uf Through Hole Cap

    0_1516915484972_esp32.bmp



  • I just wanted to say that a 10 uf cap worked great for me!



  • A 100nF SMD capacitor soldered between EN (the collector of VT2) and the shield of the ESP32 module did the job for me.

    100nF between EN collector and GND



  • As a heads up - I was having the same bang your head against the wall problem as Stanszal trying to get the "temporary" capacitor fix to work. Turns out that in addition to the capacitor being needed, there may be issues with the header connections on some of the boards. None of the GND\RESET connections worked with the capacitor thru the bottom plate. Pulled the bottom plate and plugged the cap right into the MBus header GND\RST on the system board and it's worked every time - plan is to solder the CAP patch once I get a small one.

    So - besides the capacitor issue (I really hope the fabricator reads this stuff and comes up with a fix), you all need to be aware as to why soldered boards are much preferred over solderless breadboards and header stacks. Less likely to have poor connections via solder. I love the compactness and modularity of the M5Stack (part of why I picked one up to play with) but this just underscores that you need to be wary of the header pin connections on the modules. The short pins and sockets and tight tolerances to make this what it is looks prone to connection problems.