M5StickC/ATOM on MacOS Catalina can't upload/ ESP32: Timed out waiting for packet header solution (Solved)

  • @redes-io

    All I did was show you how to change the executable permissions of the file. That was your issue. You still need to follow the rest of the instructions they provided....

    “Then connect the M5StickC device to the computer, double-click to open the tool, follow the operation prompts, press the Enter key to run, and wait for the burning to complete.”

  • @world101 Very much appreciated, thank you for the reply!

  • @world101 Remember to remove the .dms file extension, which is wrongly added by Safari/MacOS. Then you should be able to execute the file by right-clicking and choosing "open in Terminal", then follow instructions.

  • Just want to confirm this solution as working for M5Stick-C and M5Atom... I'm on latest macOS 10.15.3 (19D76).

  • @sergey-maysak Theoretically this solution applicable , and we already has test , you could try it.

  • @world101 said in M5StickC and ATOM on MacOS platform can't upload programs solustion:

    chmod +x ch552Updater_FW20200114_A2_BTV231.dms

    ==================== M5 Serial Converter Firmware Updater ====================

    FW Version: FW20200114_A2
    This is only for update M5StickC or M5Atom Series USB Controller's Firmware 

    , using it for any other purpose may cause damage to your devices.

    When you are using this software, make sure you have a reliable connection 

    to your device. Any disruption during the process will cause the device
    not functioning.

                        NO WARRANTIES

    To the extent permitted by applicable law, neither wsdot,
    nor any person, either expressly or implicitly, warrants any aspect of
    this software or program, including any output or results of this software
    or program. Unless agreed to in writing. This software and program is
    being provided "as is", without any warranty of any type or nature,
    either express or implied, including, but not limited to, the implied
    warranties of merchantability and fitness for a particular purpose,
    and any warranty that this software or program is free from defects.

    Press enter to continue . . .

    Detecting M5Stack products.
    Find M5Stack products.
    Kernel driver deteched.
    Apply magic success.

    Fail to cast magic stage 2, please contact vendor.
    Waiting for device in DFU mode.....................logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    Deleting expired sessions...153 completed.

    [Process completed]

    not working to me M5Atom LITE on osx 10.12.5

  • where is the G0 on M5Atom LITE??

  • @cepics Why do you want to upgrade ... 10.12 can support the ATOM. This upgrade tool is for those systems that don't recognize the port such as MacOS Catalina

  • I have problems to upload code on M5StickC and M5Atom LITE.....
    no serial port available in tools/port menu..

    I have also burn with easyloader (on a win machine) to reset the modules

    osx 10.12.5
    arduino IDE 1.8.9

  • @cepics you could try setup the baud to 115200. then try again. or contact our store. we will help you solve it. as soon as possible

  • @m5stack

    I'm on macos 10.15.3 and I'm asking myself too, where is G0 on the M5Atom Matrix? Although I was able to apply the described firmware, I'm not able to connect via UIFlow IDE nor Arduino IDE (1.8.9).

    By the way: almost no image gets displayed on Safari from the documentation — neither iPad nor mac.

  • @herrlehmann M5Atom Matrix have not provided G0 Pin to outside. so the solustion 1 is for m5stickC. and could you use windows os test it again? maybe is the driver software problem .

  • @m5stack said in M5StickC and ATOM on MacOS Catalina can't upload programs solustion:

    @cepics you could try setup the baud to 115200. then try again. or contact our store. we will help you solve it. as soon as possible

    no way!!! Atom serial port doesn't appear in the serial port list..... more than one cable tested....

  • @m5stack

    No, the is (un)fortunately no Windows machine. I'm a little confused about the fact, that the above mentioned firmware is running without any problem. So there needs to be a connection between mac to m5atom in some way — or how is it writing to the device?

  • My new m5stick-C are showing up on the MacOS (10.15.3) as M5 Serial Converter, and in the Arduino IDE (latest edition). I have applied the updater as suggested in this thread, and still get this response when trying to upload from the IDE to the device: "fork/exec /Applications/Arduino 2.app/Contents/Java/tools-builder/ctags/5.8-arduino11/ctags: bad CPU type in executable
    Error compiling for board M5Stick-C."

  • @rschdev clearly. this is a compiling error . you should check the error information , and check you program.

  • @herrlehmann did you installed the FTDI driver? you could try delete both below files. then connect your device try again.


  • @m5stack said in M5StickC and ATOM on MacOS Catalina can't upload programs solustion:


    I had access to a Windows machine and was able to use the easy loader on my M5Atom Matrix. It is working on Windows.

    For my mac:
    Yes, I installed the FTDI driver, but they did not work. I've removed them as suggested, but it didn't change anything. There is still no device appearing in /dev/, so it is not accessible.

  • @m5stack did you dig any deeper into this? I'm still unable to use the M5Atom Matrix on my mac with Catalina. I started over again by installing and deinstalling stuff, but no new device appears. The system recognizes the M5Atom Matrix by naming a M5 Serial Converter with following information:

    Produkt-ID: 0x6001
    Hersteller-ID: 0x0403 (Future Technology Devices International Limited)
    Version: 4.00
    Seriennummer: 79525701B4
    Geschwindigkeit: Bis zu 12 MBit/s
    Hersteller: M5STACK Inc.
    Standort-ID: 0x14500000 / 6
    Verfügbare Stromstärke (mA): 500
    Erforderliche Stromstärke (mA): 100
    Zusätzlicher Betriebsstrom (mA): 0

    I also applied the firmware update many times successfully.

    @m5stack : Any other ideas? I'd like to play with it.

  • @herrlehmann did you have try to install the FTDI driver : https://www.ftdichip.com/Drivers/VCP.htm