How to exit Core2 setup Wi-Fi Config?

  • Hi all,

    I just flashed my Core2 with UIFlow_Core2 v1.6.5.1-core2. After booting I selected Wi-Fi Config in the main menu.

    As this does not work for me, I want to go back into the UIFlow main menu on the device, but that is not possible.

    When rebooting, the setup always starts the Wi-Fi Config. Even after a re-flash it starts with Wi-Fi Config.

    There seems to be no way to exit the Wi-Fi Config menu once selected.

    I assume that it saved this state somewhere in memory, but there should be an option to go back to main menu.


    Main menu

    Wi-Fi Config menu

  • Hi Mike,
    I also just flashed Core 2.
    I recognized the same behaviour as you described, I now found that if you select UIFlow setup after reboot and select "WiFi" it works. To me a bit strange: if I download program from UIFlow Core 2 reboots and loads app. If I want to reconnect for downloading changes I have manually to reboot and again select WiFi-connection...
    I also inserted SD card as I thought it's maybe related to memory, but same.
    If I use Desktop UIFlow it's also necessary to reboot Core 2 to connect and download eachtime, is this really designed that way?

    Kind regards,

  • Global Moderator

    Have you tried connecting the Core2 to the WiFi by accessing the SSID and navigating to on your browser?

  • @zontex My old Macbook does not want to connect to the Core2, therefore I want to go back into the home menu and try other options.

  • Global Moderator

    Could you please note what Macbook you have and what version of system it is? that's abnormal. no matter what OS you are having it should work, could you give me some more details on what you are getting? failed to connect to the WiFi access point?

    Meanwhile, could you try access the M5 access point by other device such as your mobile phone and see if this can be successfully accomplished?

  • @zontex I tried again and my Macbook does connect indeed, it just does not show the usual WiFi symbol - I guess because it has limited Internet connectivity.

    It would still be great to be able to get back to the main menu - especially after re-flashing I would expect a clean start.

  • Global Moderator

    @mb It doesn't show internet connectivity because the M5Stack device is operating on AP mode (no internet connection) it expects you to open your browser and enter the IP address so you could give it your wifi credentials, once the M5Stack is connected to your wifi network you can start using it using UIFlow