m5stack fire black screen after i conected servo motor to it

  • Hi everyone , so my m5stack fire suddenly become black screen after I connected servo motor to it .

    this happened before like month ago so I tried to update the firmware and it worked and back to normal but this time when I connect it to my laptop and update the firmware it doesn't work and fail.

    btw it only make some sounds and the red led lights but the screen is black.

    also can I know why when I connect it to servo motor this happens?


  • I have a similar problem. I powerd my M5Stack core black from a Stepmotor module and was not able to connect with the WLAN for programming. So I connected a small powerbank to the USB-C of the M5Stack. After resetting the display stayed black. Using a power adapter for the USB-C port also did not change anything. The M5Stack did not start. What I found out was that the powerbank did not deliver 5V correctly ( I measured 3.7V). May there be a conflict with the charging circuit when the Core is powerd over the Stepmotormodule (12V) and a voltage lower than 5V from the USB-Cat the same time?
    Some weeks ago my M5Stack grey stopped working when i tested a LEGO+ module.
    Now I have a black and a grey module and both displays keep dark and are not working.
    Any ideas?

  • @m5stack , @ajb2k3 sorry but any ideas?