UIFlow 1.7.3

  • @felmue False joy ! the PaHUB is now recognized by CORE2 with
    But only the first connected I2C module works, if you connect another I2C module it is in error. Tests carried out with Ultrasound, TOH amp, Joystick modules ... whatever I2C module you connect to in PAHUB0 is working, all the other ports are in error with message: Joystick unit maybe not connect or Ultrasound nit maybe not connect.

    ![0_1616000524477_P1110077.JPG](Uploading 100%)


  • Hello @Peter

    I'd love to. Unfortunately I am just a user like you w/o access to UIFlow source code.

    Hopefully M5Stack engineers will look into that soon.


    P.S. As a work-a-round in the Python tab you can modify the line for the unit connected to Pa.HUB manually. Not ideal but this works for me.
    E.g. from

    AMeter0 = unit.get(unit.AMETER, unit.PORTA)


    AMeter0 = unit.get(unit.AMETER, unit.PAHUB0)

  • Hello @Arno

    I think set pos X open is the wrong command. According to the help text it only opens one position and closes all others. Try set pos X state open instead.


  • Just by adding the PaHUB + ultrasound + Joystick units without any line of code, I have an Ultrasonic unit maybe not connect error.
    It's the same with other I2C units



  • Hello @Arno

    I only have an ENV and Ameter unit and I can use them together just fine with the Pa.HUB and M5Core2.

    • Do the units work ok, when used w/o Pa.HUB?
    • Does a single unit work on all ports of the Pa.HUB?
    • Are you sure you have your units connected to the correct ports?
    • Did you try to reset M5Core2 in case some previous code is running?

    If it's only some units that fail I am afraid I cannot help as I don't have any other units to test with. Sorry.


  • @m5stack Great Update!

    I try AWS blocks on 1.7.3. In this version subscription don't work(MQTT connect and publish is fine)

    Then I try This version don't connect to AWS IoT Core.


    Is there a way to see the device log?

  • Hi @fonix232 @ajb2k3 @robalstona @Arno @felmue @weezer @Thrasher @Peter ,
    Sorry to everyone, today I will deal with the PAHUB problem, please forgive me for not solving it for a long time.
    Regarding the open source requirements you mentioned, I can't make a decision at present, please understand.

  • @sparkgene said in UIFlow 1.7.3:

    @m5stack Great Update!

    I try AWS blocks on 1.7.3. In this version subscription don't work(MQTT connect and publish is fine)

    Then I try This version don't connect to AWS IoT Core.


    Is there a way to see the device log?

    Have you made sure AWS is set up properly?

  • @iamliubo M5Stack isn't open source and never will be. They will never disclose their micropy libraries (well, not even documentation).
    All questions here about it are taboo and will be left unreplyed. Best solution is to use UIFlow blocks if u want to prototype something. Otherwise its better to switch to another hardware. However, I love build quality and designs.

  • Hi @sparkgene ,
    Just missed AWS Start block.

  • Hi @thrasher ,
    Maybe one day we will open source. :)

  • @iamliubo

    I'm getting the error "aws isn't defined"

  • @ajb2k3 Yes. I can publish and subscribe with same setting when I use AWS IoT SDK.

  • @iamliubo I didn't recognize that. Thanks. It's working now on

  • @iamliubo I'm glad to here that you're going to work on the PaHub problem. I think that is important for the user community to know that there is someone looking at issues and working for fix them. It may takes time to fix an issue but if I know that someone in M5Stack is working on it I'm happy and I can wait.

  • @sparkgene @IAMLIUBO Why is the AWS blocks greenyblue in those pictures but yellow on my screen?

  • @ajb2k3 I'm not sure, but first it was blue. The latest is yellow(orange?) on my screen too. BTW Try to use the latest uiflow image v1.7.3.1. The error "aws isn't defined" will be fixed.

  • @sparkgene I solved the AWS not defined issue as it was due to incorrect placement of the Start block.

    I'm just back to the "Cannot create thread" error and completely lost.

  • So Now it works ( Had a permission issue on AWS) however I have an issue with the AWS blocks.
    @IAMLIUBO return topic doesn't return the topic and there is no return topic payload block.

  • @fonix232 said in UIFlow 1.7.3:

    A kinda related, but strange question - could you please release the source code for the drivers of the various bits of hardware found in the UIFlow firmware? UIFlow is built upon MicroPython, and I would personally prefer to run a clean MicroPython build on a few devices of mine, however the lack of drivers makes it a bit harder than expected. I'm not interested in the UIFlow-related parts, just the low level Core/Unit/Module support drivers (e.g. for M5Paper, a driver for IT8951, a driver for the PMIC, SHT30, GT911). It would allow the community to build MicroPython images without proprietary code, and possibly result in faster updates as well. Plus, you could merge back community fixes into the official UIFlow firmware easily.

    Same thing for me.
    But I like uiFlow tool to test the code.
    For example, Update the UIFlow-code project on git with core2 libs would be cool
    Best reguards