Upload Code Failed

  • I have been using the Core2 for awhile now. So am familiar with "downloading" an app into the core. Today I was expanding an app and it would "Run" just fine for testing. When I went to "download" the app it came back with an error that state "Upload Code Failed". I reflashed the Core2 with an earlier version of firmware same result. Rebooted PC same result. Loaded an earlier version of this app that had about 465 lines of python code and it "downloaded" just fine.

    So, the app in question is now larger at 785 lines of python code, not sure if that has anything to do with it or not. The Core2 will hang with "Uploading" until it is rebooted. I tried a 2nd Core2 same results.

    I am using UIFLOW desktop version V1.7.5 with firmware version V1.7.8

    Any insight into how to resolve this would be greatly appreciated.

  • Ok, here is what I found even though it said the Upload failed and it hung up on the Core2 saying "Uploading" After I reset the core2 it didn't automatically boot to the app but if I went to the app list on the core2 it was there. I selected it and then selected "Run" and nothing happened so I reset the Core2. After resetting the Core2 it automatically booted the app. I guess I will contact Tech support and ask them what is going on. Hopefully this workaround will help someone else.

  • I am experiencing the same symptoms with my M5Paper and Windows 10.
    If I run and download an m5 file that contains about 1400 blocks it does not work, but if I delete the blocks to make it about 400 blocks it works.

    M5 paper
    This problem occurs with all combinations of UIFlow-Desktop-IDE (Win) v1.0.16, v1.0.17 and firmware versions v1.7.7, v1.7.8.

    A sample m5 file (about 1250 blocks, the event also occurs with this file)

    These m5 files used to be able to be run and downloaded in conjunction with UIFlow(Web), but UIFlow(Web) is no longer available, as shown in the following topic.