Battery issue

  • Hi,

    recently I have purchased two M5Stack cores, the problem is that in both these devices battery charging doesn't work. Accoring to circuit diagram, IP5306 IC should charge built-in battery using USB port. Is there anyone out there having similar issue ?

  • Sorry for late reply. Has the problem been solved? Bottom base of devices you have all can not be charged ?

  • I haven't solved it yet. Yes both bottom modules can not be charged. Have you had similiar issue ?

  • I have the same problem, I think.
    There is absent +5V at the bottom board.
    But, when I press the bottom to main board with a great force, this problem is out.
    As for me, there is a bad contact on the connector between mainboard and bottom.
    And I don't know how to fix it ((

  • Maybe the usb device went to power saving mode.

  • I have the same problem too.

  • I was having the same issue. Now fixed.

    Seems the problem was that the USB hub that my M5Stack was connected to did not put out enough power to CHARGE the M5Stack Battery Module. It worked fine for powering the M5Stack and then uploading sketches - but not for charging.

    Fix: Connected M5Stack to a Ravpower rechargeable USB power bank. Alternatively you could use a suitable power transformer.

    Testing: Checking the pins on the bottom module I now get - 3.7 volts on the BAT pin; 3.3 on the 3.3V pin ; and 5V on the 5V pin. I did not get these readings before using the Ravpower.

    I checked the USB ports with a Keweisi USB power tester. The USB hub was only providing 4.33 volts. The upstream USB port on the Dell PC it was connected to was delivering 4.99 - 5 volts. Whereas, the successful Ravpower was providing 5.3 volts.

  • I also have the same problem.
    My bottom base doesn't load the small battery.

    I have tried with usb2, usb 3 computers, and mobile chargers.
    I don't know what to do, any hint?
    I don't have a tester here.

  • @kaotiklabs

    Hi. Have you tried a powered USB port ? That is, a USB port with a transformer connected to it providing direct power. USB 2 or 3. * Ideally without other devices connected to it. * This last point can be important.

    With a transformer and with no other devices connected, you should then get 5 volts which is the recommended power input for the M5Stack. It may be OK with a low power device also connected to the USB like a USB stick, but not a mechanical keyboard with RGB lighting or similar higher power device like a gaming mouse.

    For me, this solution has worked very well with no more flattening of the battery while connected to the USB and loading sketches.

  • @vvs551Battery issue 中说:

    I have the same problem, I think.
    There is absent +5V at the bottom board.
    But, when I press the bottom to main board with a great force, this problem is out.
    As for me, there is a bad contact on the connector between mainboard and bottom.
    And I don't know how to fix it ((

    I have similar obeservations...
    Solved this by a little deflection all header pins on bottom board
    but it looks like it's a base plate female header problem, not bottom male header,
    because when I got battery board then problem back and in this board I also had little move header pins
    something like this: from IIIII to IIIII

  • @JimiT I have also tried with a powered USB port with a transformer. No way.

    Is there any way to read from code if the battery is charging? any GPIO reading?
    I'm trying to press the bottom to main board but don't know if it's working. It doesn't seem to be charging anything.

    I will try to move pins but I'm afraid of breaking something. I have paid 60$ for this core module :( Not cheap and by the moment faulty.

  • @kaotiklabs
    I've tested quite a few units and I haven't had any problem with the base connecting - so I can't comment on that. Looks like reaper7 had some success with that.....

    I haven't seen any code for M5Stack that shows battery charge level - there may be some out there from another device that could be adapted, but that won't help you now.

    So, to step back, M5Stack works connected to the USB port which has a power transformer & no other devices connected to it. After leaving it connected for a few minutes, when you disconnect the M5Stack from USB power the M5 screen shuts off immediately? Is that right? Or does it take some time before it shuts off ?

    If it's off immediately then yes seems the battery is not charging. If it stays on, its charging.

  • Yes, @JimiT. It goes off immediately after being connected for more than 30 minutes. Not charging at all.
    As some of you stated before, must be a pin header problem.

  • @kaotiklabs

    Hi, had no answer earlier.... if the pins don't look bent and if the modules fit together without issue and they are properly pushed together (no great force should be needed), then it's possible the problem might lay elsewhere. The battery itself or it's connection.....

    I just found one of my units - an earlier model [not PSRAM model] - has this issue too. I connected the optional battery module and it works fine with that connected and no USB power connected. If the above is true for you, then my suggested solution is to shell out for the battery module. I know this means more $$$ but if you are to use it regularly you'd probably want it anyway. Is a great addition.

    Have you seen Tom's menu system for the M5....? With the direction this thing is going in, IMO it's worth the pain of the extra $$$. It's getting more powerful by the day. (Will inspect my bottom module when I have a chance....).

  • I have tried to inspect my bottom module but don't have a tester right now. At first view it seems ok but who knows.

    Yes, it's a promising device. I'm also working on integrating it with my domotic light system and I'm having good results!

  • @kaotiklabs Try to connect the device to the charger and then put the device to sleep mode (the SimpleApplicationMenu example can do that) and wait for one hour. Did it improve the charging ?

  • As per my other post, I too have battery charging issues. My M5Stack will only work consistently with the bottom off. And yes, I tried different USB power sources which I monitored via a USB power meter. All were solid. I will try the SAM sleep mode just for kicks.

  • @kaotiklabs did you test with a battery connected directly to the connector on the main board?

  • @DoNcK I have tried charging while in sleep mode without results.

    @pkourany wich connector do you refer? I will try to test that.

  • @kaotiklabs, I tried charging while sleeping and no go, the battery does not charge and The M5Stack runs seconds before shutting down.

    I have the latest PS-RAM unit and there is a battery connector on the on the motherboard.
    However, I haven't been able to tell which side of the connector is + and which is -.