Timer Camera X - Burning

  • I recently purchased a couple of m5 timer camera X's. I am new to m5stack. though I have been programming ESP32's for around a year using ESP/IDF VSCode on Linux . I have developed software for the esp32-cam AI thinker and other espressif boards.

    I was able for get the camera running after setting the wifi supplicant using the windows based camera tool.

    I tried to set the m5 cam x's esp32 into flash mode for esp flashing with idf, but that does not seem to work for this device. Tried the two buttons in various sequences. No luck.

    So, I downloaded the m5 burner, and was able to erase the device. On boot I now get

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    invalid header: 0xffffffff

    I tried burning packages/fw/timercam/TimerCam-v1.0.bin , but get the following error:

    (node:11227) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, open '/home/david/projects/m5stack/M5Burner_Linux/packages/fw/other/timercam.cfg'


    Can I set the m5 camera x device into flash mode so I can use esp-idf tools?
    Where can I find timercam.cfg?
    What baud rate should I use?