Can't load program modifications...

  • I have a Core2-AWS and trying to learn how to use it. I've done a lot of programming with Arduinos in the past...

    I had a program loaded into the M5Stack, and then went back to the M5Burner and loaded the UIFlow for the Core2 (top of the list).

    My M5Stack comes up as Com9 and I can load in my original "Hello World" that I wrote some months ago. However, I can't see to do any mods to the program and get them to load (adding a box/label/sound, etc.). The UIFlow just says that it's disconnected.
    I'm trying to figure out how I would go about writing and debugging a program, adding code, etc... Keeps saying that it's "Disconnected".

    I tried via USB (local UIFlow exe) and TCPIP (Browser editor), but it always says that the device is disconnected. Tried "Reset" and restarting...

    What am I doing wrong?

    Sir Michael

  • I gave up... There were no answers and I couldn't get UIFlow to work.
    Went back to Arduino IDE.

    Sir Michael

  • @sirmichael If you HAVE experience with Arduino IDE and C, C++, then I agree that Arduino gives more control at a deeper level and IMHO worth the extra effort.
    Arduino for ESP32 however changed that, when Espressif took over the board config, "updated" ESP_NOW such that older Arduino Sketches would no longer run, and Arduino-as-slave was never implemented, both causing me hair-loss!

  • Have you tried Using M5Burner to erase the flash first before installing Core2 firmware?
    You MUST make sure to install Core2 and not Core firmware.

  • @teastain,

    I haven’t gotten very far in learning the UIflow enough to learn if it supports the “tabs” like the Arduino ide. I have some libraries that I often include in my sketches (i.e.: Morse code for error messaging) and it’s easier to put all of the buttons in one file, display in another, subroutines, etc….
    Does UIflow support anything like that? Files?

    I’ll be honest, I don’t understand enough about the ESP32 to understand about your references to Expressif. I have used an ESP32 for the Bluetooth as a solution to a problem that I had, but I am not using it at near its capacities.

    And to ajb2k3, I am in fact using the M5burner with the Core2 (as mentioned above). It’s working, but just slow…. As a matter of fact, even the Arduino compiler is slow.
    I think that I may have some other interaction issues with some other install somewhere.

    Sir Michael

  • Slow response could be down to having the wrong baud speed set. UIFlow is built on Micropython and so does support multi files like arduino. Checkout Micropython. Org

    Esp is not like the arduino as instead of having functions permanently assigned to a pin, the esp using a matrix to assign functions to pins