M5 stack core 2 is disconnecting

  • Hello everybody,

    I just got my M5 stack Core 2 and I am trying to use it in the micropython environment.
    I was able to connect it to my wireless account, I developed a simple Hello World program and Sent it to the device. Fine. However as I am trying to sent a second program, the device is disconnected. My assumption is that the program is saved as main.py so it starts at power on.
    How can I interrupt the program and connect Ui Flow to the device ?

    Thanks a lot for any answer.

  • Did you use the Download button or the run button?
    I've noticed this happen from time to time but today it didn't do what you described.

  • Actually I used the Run button.
    In order to solve the issue, I burned again the device..
    I then tried to connect on COM3 (the COM that worked for the burning) with the new API key.
    I get the message :upload failed, check if the device is offline.
    I used another ISB cable.. same issue. I am no longer able to connet to the Core 2 with UI Flow and can't figure why..

  • I am a bit puzzled by the lack of answers. 145 views and only one post.
    Are all of the readers satisfyed by the connection between UIflow and M5 ?

    Right now I am using the Web version of UI flow as I read on a previous post that the Desktop IDE is no longer current. Is this still the case or should I use the desktop IDE ?

  • Hello @csierra67

    more or less, yes. There are some hiccups from time to time for me, but overall the connection between Web UIFlow and various M5Stack devices is fine.

    No, do not use the desktop IDE; it is hopelessly out of sync and no longer maintained.


  • The Desktop is unmaintained for a long time so please don't use it.
    The M5Stack server is located in china and from time to time we lose access to the server due to the great firewall of china.

  • Hi Felix,

    Thanks !
    Actually despite the message on the Internet (terminated) and your answer, I gave it a try and
    desktop IDE could connect to the device !
    There must be something wrong with the web App

  • @ajb2k3 One thought following your comment.. I am using Bitdefender Total Security
    Could it interfere with the chinese firewall ?

  • @csierra67 possible, America is trying to block Chinese things at the moment.
    Mostly its probably just server overload.

  • I momentarily stopped the firewall of my PC, same problem.

    I finally found THE solution. Actually my connection to UI Flow was by cable and UI flow did not find COM3 unlike M5 burner
    I moved to Wifi connection. This time Web UI flow connected..
    I guess this is the solution to my problem and may help future newbie to solve the issue.

  • @ajb2k3 said in M5 stack core 2 is disconnecting:

    America is trying to block Chinese things at the moment.

    alt text