How to interrupt a program saved on M5 Stack Core 2 ?

  • Hello everybody,

    I am still learning how to operate efficiently the device (configured to start in Internet mode).
    In "development" mode, I run the program with the arrow and once done, I switch it off and on restart it is connecting to my wireless network with a scree reminding me the AP key, I then open UI flow and reconnect.. Fine.
    However as I download the program to the M5, upon start I get a menu with 3 possibilities : Apps, UI flow and Setup.. I tried to select any of these options but it does not work. The bootprocess goes on and starts the program saved on the M5.
    This goes on for ever and prevents also UI flow to access the M5 as it is busy running the program..
    The only way I found as of now is to burn the M5 again, this gives me again control.
    I would be very thankful if you could answer my questions.

    Is the solution to burn the M5 from scratch the normal way of doing or is there a better way ?
    Assuming there is, is there a physical button to stop the program.. M5 Core has physical buttons, Core 2 seems to have capacitive button but they don't seem to work..

    Any answer/comment is appreciated..


    To make a paralell with Arduino, once the program is loaded on a device, there is generally a reset button that stops the program and puts the MCU in download mode
    In a similar way, under Micopython and Thonny, the program must b stopped to get control of the device..

  • It does work but the delay is so small that it takes timing to do. I often loose my patience with it and resort to opening M5Burner and altering the boot process using the config options.

  • Thanks for the answer. So what I thought to be a last chance solution becomes the rule. In the videos and tutorials I have been through so far, this question has never been raised. One is told how to download a program to the device starting from scratch but never how to download program number 2..