Problems loading after Arduino updates

  • Is anyone else having problems with Arduino upload to device after updates today. I'm able to flash the 2x Core2 with Burner, but if I try anything on Arduino I get this in the serial terminal. Any thoughts how to flash or repair? Or maybe something within IDE has gone wrong.
    rst:0x3 (SW_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)

  • @gavin67890 This is a new 'shame' for the Arduino crowd.
    Old established projects on traditional cores won't compile after a boards def or library update.
    It is sometimes the fault of M5Stack and sometimes Espressif updating their board 'cores'.
    M5 has to scramble to keep up and make theirs compatible.
    So, to test I re-compiled and uploaded both my huge projects on a Core Basic and one on Core2.
    Both compiled and uploaded successfully.
    Arduino 2.2.1,
    ESP32 2.0.14,
    M5Stack 2.0.8
    I run with the latest updates all the time trying to keep ahead of the game.

  • Hmm, I get that. And appreciate that some of what we are doing here is frontier work, but when breaking changes result in the most obscure error messages know to man it's still a bit painful. The catch to response to repair time is perhaps something the community could work on, with and without GitHub.

    I'll cheer up after a nights sleep.

    I've still no idea on a fix for the fault posted. Likewise, I have had to swap from M5Core2 to M5Unified for an error earlier this am, so any other thoughts gratefully received.

    Update: same Arduino v2.2.1 --> PC fine, macOS the above error [groan], again.

  • Banned

    This post is deleted!