OSX Easyloader

  • Re: [Custom EasyLoader](/topic/1771/OSX easyloader)

    Hi --
    It is not made clear on the M5STack website that the Atom is not programmable with OSX or Linux, but only with Wondows! I own several useless Atoms.

    When will a method of programming these little wonders be made available? Or open source it, and let the web do its magic.


  • @dpharris

    Edit: I haven’t seen an update on easyloader yet for OSX. In the meantime, use Arduino or uiFlow to program the Atom and m5burner to flash the firmware.

  • You have installed the drivers properly have you because I have several Atoms and I can program them fine in Arduino and UIFlow

  • @ajb2k3
    You can program them on OSX?

    If so, how do you do it?

    Thx David

  • @dpharris

    in this page you could choice the program platform. and click the category card view the Quick Start.


  • @m5stack
    Thanks for that. I have loaded all the libraries. I have tried choosing M5StickC or ESP32-Pico for the AtomMatrix. Neither the Atom, nor the M5StickCs will load. I can load after powering up with G0 grounded.

    I have OSX 10.10.5. I have tried the Updater_FW20200422 py program, but it fails.

    Thanks for any advice!


  • 10.10.5?
    I'm running 10.14.2 (mojave) and can program using UIFlow and arduino.
    It could be that you OSX is too old to support it.
    Have you installed python3 ?
    what is the error message that the updater returns?

  • Hi there

    Although I don't have a solution I wanted to share my results regarding flashing M5StickC, M5AtomLite and M5AtomMatrix . I am using VSCode/PlatformIO on two Macs with different OS:

    • OS X Yosemite (10.10.5):
      M5StickC (success), M5AtomLite (fail), M5AtomMatrix (fail)

    • macOS High Sierra (10.13.6):
      M5StickC (success), M5AtomLite (success), M5AtomMatrix (success)

    Checking System Information / USB I can see that M5StackC reports version 4.00 and the two M5Atoms show version 5.00.

    Anyways, from System Information / USB it looks like the custom USB chips in M5StickC and M5Atoms report as FTDI but I guess they aren't perfect copies and therefore different results are seen with different setups.


  • Hi there

    some additional information: same Mac, same OS X Yosemite, same USB port, same USB cable and same M5AtomLite / Matrix, but using a virtual machine running Ubuntu 18.04 and flashing works just fine. I guess this suggest that there is some subtle difference in the FTDI driver of OS X and Ubuntu.


  • I finally loaded Windows 10 into a VirtualBox VM, and that works for me.