Core2 Rebooting with program change

  • I have a program that I don't consider excessively large. It mainly has 6 different screen layouts along with that overhead. The file size is 97K. It has reached the point that it runs as is but if I add anything to it (ie: If I change the wording of a label) will not run and the Core2 resets itself. I have tried from v1.7.0 up to 1.7.2 with the same results. So, have I reached size limitation? If so how do I tell available space and what is being used? If anyone has any suggestions it would be greatly appreciated. I am using Blockly which is translated into 477 lines of Python.
    Thanks for any insight.

  • @se
    Try Download instead of Run to see if it helps. Also delete any preinstalled apps that might come bundled with the uiFlow firmware via M5Burner. I think they are in /flash/apps if there are any.

    My largest uiFlow program is 88.9 KB, so I’m under your program size. I’m running that on an M5StickC+. On the Core2 my largest is 75 KB.

  • Thanks for the feedback. After flashing the Core2 to a different version. It wipes out all my apps and leaves behind a Color app and temp app. Since they don't show in the Device File manager I think they want them left alone. I assume the color app could go but not sure how to delete without Device File Manager. The "Temp" app probably needs to stay. Your suggestion did get me to look a little closer I had spaces in my file name (should have known better) which resulted in the Device file manager splitting it into "3 Files". I assume that it created 2 empty files and actually 1 real file with my app. Anyway couldn't delete them so re-flashed to clean it up. When "Run" it, with additional code, it causes the device to reset without ever seeing the app run. If I "Download" it, after adding some additional code, it does not reset the device and appears to run. Might be something with RAM. Tried a different Core2 with same results. Here is a pic of the filename and the way it split it. If you have any additional suggestions that would be great.

    Also have you seen instances where the buttons along the bottom of the screen don't process their "Press" code as well as the soft "Button" you place on the screen doing the same thing. I will have things working properly and not touch the code for those routines and next thing I know they aren't processing anymore. If I through a label into the press routine, for output, I don't see it change either like the button press is not being recognized. Thanks again

  • It is definitely something to do with the size of the program. Once it reaches a certain size it will no longer run. All I have to do is delete anything (reducing the size) and it will run again. I provided a sample of my code to tech support and they are working with engineering to investigate.