Name 'module' isn't defined (BaseX with UIFlow)

  • Dear Member,
    Up to now, I could use UIFlow and BaseX well with my M5Fire. Recently I updated my UIFlow(Fire) to version 1.8.2-fire and suddenly I couldn't run my script anymore. What is wrong with the new firmware and/or UIFLow IDE? I have tried both the online and offline versions of UIFlow. The results were the same.0_1628914371379_IMG_20210814_130830.jpg 0_1628914379801_IMG_20210814_131007.jpg

  • Hello @liemph

    do you remember which UIFlow firmware version you had on your M5Stack Fire before?

    I've just tried with M5Core2 which shows the same error and went back to UIFlow firmware 1.7.0 (which is the oldest I still have for M5Core2) and it's broken there as well.

    This suggests it has been broken for a while but so far nobody tested and / or complaint about it.


  • Hi @felmue
    Thanks for the effort to check. Unfortunately, I forgot the last version of the firmware which worked well. This makes me sad (and angry actually). The problem is I could not roll it back because I could not find older versions in the M5Stack repository. So what should I do? It is an expensive base and I need it to drive my Lego motors for my recent project. The M5Stack and its base module are commercial products but the quality assurance of the software and firmware are questionable. I hope the M5Stack people in charge would handle this issue quickly.

  • @m5stack @lukasmaximus Could you help to resolve this issue? If the new firmware is not yet fixed, please provide the older version which I can use. Thanks!