Battery issue

  • @kaotiklabs
    I've tested quite a few units and I haven't had any problem with the base connecting - so I can't comment on that. Looks like reaper7 had some success with that.....

    I haven't seen any code for M5Stack that shows battery charge level - there may be some out there from another device that could be adapted, but that won't help you now.

    So, to step back, M5Stack works connected to the USB port which has a power transformer & no other devices connected to it. After leaving it connected for a few minutes, when you disconnect the M5Stack from USB power the M5 screen shuts off immediately? Is that right? Or does it take some time before it shuts off ?

    If it's off immediately then yes seems the battery is not charging. If it stays on, its charging.

  • Yes, @JimiT. It goes off immediately after being connected for more than 30 minutes. Not charging at all.
    As some of you stated before, must be a pin header problem.

  • @kaotiklabs

    Hi, had no answer earlier.... if the pins don't look bent and if the modules fit together without issue and they are properly pushed together (no great force should be needed), then it's possible the problem might lay elsewhere. The battery itself or it's connection.....

    I just found one of my units - an earlier model [not PSRAM model] - has this issue too. I connected the optional battery module and it works fine with that connected and no USB power connected. If the above is true for you, then my suggested solution is to shell out for the battery module. I know this means more $$$ but if you are to use it regularly you'd probably want it anyway. Is a great addition.

    Have you seen Tom's menu system for the M5....? With the direction this thing is going in, IMO it's worth the pain of the extra $$$. It's getting more powerful by the day. (Will inspect my bottom module when I have a chance....).

  • I have tried to inspect my bottom module but don't have a tester right now. At first view it seems ok but who knows.

    Yes, it's a promising device. I'm also working on integrating it with my domotic light system and I'm having good results!

  • @kaotiklabs Try to connect the device to the charger and then put the device to sleep mode (the SimpleApplicationMenu example can do that) and wait for one hour. Did it improve the charging ?

  • As per my other post, I too have battery charging issues. My M5Stack will only work consistently with the bottom off. And yes, I tried different USB power sources which I monitored via a USB power meter. All were solid. I will try the SAM sleep mode just for kicks.

  • @kaotiklabs did you test with a battery connected directly to the connector on the main board?

  • @DoNcK I have tried charging while in sleep mode without results.

    @pkourany wich connector do you refer? I will try to test that.

  • @kaotiklabs, I tried charging while sleeping and no go, the battery does not charge and The M5Stack runs seconds before shutting down.

    I have the latest PS-RAM unit and there is a battery connector on the on the motherboard.
    However, I haven't been able to tell which side of the connector is + and which is -.


  • @bin @pkourany @kaotiklabs

    Hi, off hand I'm not sure which is + and -.

    I believe the connector on that is a JST SH with 1.0 pin pitch with side not top mounting. But you will be doing well to have one of those on hand !! They can be purchased though.

  • The positive pin is on the side of the 2x15 connector, the negative one is on the side of the SD slot.
    I also presumed the size is JST SH and order a battery, but I cannot confirm yet.

  • I have a proto module and will connect a known good 3.7v LiPo to the BATT terminals and try charging and using it. If that dosen't work, I will test battery via JST SH on main board. I have a strong suspicion the charger may not be working.

  • I tested with a battery connected to the VBAT and GND terminals of the proto module. I now realize the issue is with the charger chip:

    • A fully charged battery will boot the unit and it will run for a few seconds and then turn off
    • Without any battery, the M5Stack often will not power up when USB is plugged. I need to press the power button several times to get it to power up. Often, that won't even work. The same applies when powered by battery only or battery + USB power.

    I now believe I have a defective M5Stack unit. How do I go about getting a replacement?

  • @m5stack @bin @pkourany
    Hi, probably depends whether you purchased from a reseller or from M5Stack.

  • Purchased from official store on AliExpress.

  • @pkourany Hi, there is a link on their store page - "Contact Now". Just go to one of the product pages.

  • Done!

  • @jimit 在 Battery issue 中说:

    believe the connector on that is a JST SH with 1.0 pin

    Can somebody confirm 100% sure the connector format ?

  • @donck Hi, this is not "official", but I'm pretty confident this is the correct spec for a cable to connect to the battery socket on the M5:

    JST SH - 2 pin - 1.0 pin pitch - Side mount (not top mount like many LiPo connectors)

    The point about it being side mount is critical.

    The plug connecting into the battery socket on the M5, should have lines on the sides that connect into the grooves that you can see in the socket on the M5. These are horizontal lines. The lines need to be around half-way up the body of the plug - not at top or bottom.

    I measured with digital calipers & compared against other similarly sized JST cables of known size - so I'm pretty sure it's correct.

    Remains untested at this point however.

  • My m5 faces will not charge. It does not draw any amps. You all need to work on this issue. Plus my m5stack core doesnt hold a charge longer than a day.