M5Burner does not work in MacOX 12.3.



  • Hi, everyone!
    M5Burner does not work in MacOX 12.3. I checked it to work in 12.2. I heard 12.3 deletes python module. I tried to install python2 to run M5 Burner. But it does not work. I would like to use UI Flow. So, M5burner need to install UI Flow. Do you have any idea?

    Thanks
    oyouji



  • I can confirm this issue. I am also unable to use the M5Burner on macOS Monterey 12.3.



  • @oyouji I found a workaround to get the M5Burner working. I installed pyenv with Homebrew and then installed python3 using pyenv. I then had to launch M5Burner from the command line so it had access to the newly installed python3. I did this buy running "/Applications/M5Burner.app/Contents/MacOS/electron-m5burner-v2-eletron".



  • Same problem here. Program become non-responsive, requires Force Quit.



  • Hello,

    I tried re installing python 3 and running the executable from the command line but I get a Java error
    Has anyone got this to work?
    Its frustrating!



  • this is the error I get

    Uncaught Exception:
    Error: spawn python ENOENT
    at Process.ChildProcess._handle.onexit (internal/child_process.js:264:19)
    at onErrorNT (internal/child_process.js:456:16)
    at processTicksAndRejections (internal/process/task_queues.js:80:21)



  • I had the same problem.
    I referred to joshrhyked's post, and I succeed burn with the following steps.

    1. Start Terminal App.

    2. Install homebrew.
      Please refer to the installation on the page.
      https://brew.sh/

    3. Install python3
      Please type the command.
      $ brew install python3

    4. Put a symbolic link
      $ sudo ln -s /usr/local/bin/python3 /usr/local/bin/python

    5. Start M5Burner on Terminal
      $ /Applications/M5Burner.app/Contents/MacOS/electron-m5burner-v2-eletron

    best of luck to you!



  • @yopita said in M5Burner does not work in MacOX 12.3.:

    I had the same problem.
    I referred to joshrhyked's post, and I succeed burn with the following steps.

    1. Start Terminal App.

    2. Install homebrew.
      Please refer to the installation on the page.
      https://brew.sh/

    3. Install python3
      Please type the command.
      $ brew install python3

    4. Put a symbolic link
      $ sudo ln -s /usr/local/bin/python3 /usr/local/bin/python

    5. Start M5Burner on Terminal
      $ /Applications/M5Burner.app/Contents/MacOS/electron-m5burner-v2-eletron

    best of luck to you!

    Step 4 is not correct but I see it worked for you.
    Open terminal and go to settings, you should be able to add /usr/local/bin/python3 to the environmental setting or find the environmental file and add it it there.



  • @yopita
    https://github.com/Xinyuan-LilyGO/LilyGo-T-Call-SIM800/issues/139#issuecomment-1014816668

    It worked for me

    System:
    MacOS Monterey 12.3.1 (Macbook Pro 2019 Intel)

    Device
    M5Stack Core2

    • Install the driver CH9102_VCP_MacOS_v1.7 > CH34xVCPDriver.pkg
    • Run the app CH34xVCPDriver in Applicatoins
    • GO TO Security on Settings and allow the app to run
    • Start Terminal App.
    • Install homebrew.
      Please refer to the installation on the page : https://brew.sh/
    • Install python3
      Please type the command.
      $ brew install python3
    • Put a symbolic link
      $ sudo ln -s /usr/local/bin/python3 /usr/local/bin/python
    • Start M5Burner on Terminal
      $ /Applications/M5Burner.app/Contents/MacOS/electron-m5burner-v2-eletron
    • Select COM port wchusbmodem


  • @waqast

    I couldn't solve it.

    When I input this command

    $ sudo ln -s /usr/local/bin/python3 /usr/local/bin/python

    it comes out this message

    ln: /usr/local/bin/python: File exists

    Do someone know how to solve this?

    Thanks



  • You need to set the path in BASH's environment setting (if bash is still used) google for setting Micropython Environmental Patch in OSX. I can't help because my OSX is several version behind and won't be updated until I can afford to by a new MAC.



  • @waqast When I follow these instructions, wchusbmodem does not show up as an available port in M5Burner. I checked in /dev and it is not there. The only port that M5Burner offers to me is /dev/tty.Bluetooth-Incoming-Port. My hardware is 2017 iMac5k MacOS Monterey12.3.1, M5Stack Core. Can anyone help?



  • @rickkaye Try to turn M5stack off, then plug it in! Do not turn it on by yourself.



  • @rickkaye Take a look in "Security and preferences" to see if the driver has been blocked.



  • I updated today to macOS Monterey V 12.3.1 and everything is fine with M5Burner MacOS x64 v3.0



  • hello,
    I could resolve the problem by changing the part of putting a symbokic link like below.

    sudo ln -s /opt/homebrew/bin/python3 /usr/local/bin/python

    The install path of python3 with homebrew is changed to /opt/homebrew/bin directory as the default in M1 mac.

    System:
    MacOS Monterey 12.3.1 (Macbook Pro 2021 M1 Pro Max)

    Device
    M5Stack Fire