uiflow 1.1 m5stick no api key

  • I loaded the new 1.1 firmware onto the stick and I set the ssid and password for the network. When the board resets it isn't showing the api key. I've tried a few times to go through this process but it just isn't showing up with the api info. The stick worked with the previous firmware. What can I do to get the info from the board. thanks

  • Have you loaded the correct firmware as there are several versions depending on base unit but the current version is 1.3

  • @jpilarski

    Have you burt the stick firmware

  • I am using 1.1.0 firmware for the stick (you circled 1.0.0 but I am assuming you meant 1.10). I am able to set the wifi after installing firmware but it never shows the screen with the api key. Can I get the api key in a repl shell or someother way because I do think it's working except it's not showing me the key.

  • @jpilarski No, he circled the "Stick" part of the file name.
    Give me 24 hours as my stick just turned up so I will see what happens tomorrow.
    Have you got arduino installed?
    You could try connecting with arduinos serial monitor to see if that works.

  • I think what was happening was, for some reason, flow.py was never being loaded. I manually ran flow.py from the console and it allowed the m5stick to finally go to the api key screen. I noticed in the code it mentions you can press button A to generate a new api key but for some reason it wasn't working. Anyways now it's good and I am successfully programming the stick as we speak. thanks

  • @jpilarski Glad to hear it.

  • I've just taken several goes to write the firmware (I think my W7 laptop to blame).
    It kept getting stuck in bootloader mode and wouldn't leave.
    Finially got it to program and reset after pressing the on/off button twice.