M5Stack Basic V2.7: can't install library M5Stack

  • Hi all, @m5stack

    I've installed

    1. the board M5Stick-C-Plus and the library M5StickCPlus: all is fine! Run sucessfully many sketches on the Stick
    2. the libraries M5Unified and M5GFX: all is fine, both are great libraries (congrats to the developers)!
    3. now I installed the board M5Stack-Core-ESP32 (Basic V2.7): looks good
    4. installing the library M5Stack failed with error message "Failed to install library: 'M5Stack:0.4.5'. No valid dependencies solution found: dependency 'MODULE_GRBL13.2' is not available"
    5. manually installing "MODULE_GRBL13.2'" and then install M5Stack again, leads to the same error message

    running the "Hello World" program with #include <M5Unified.h> instead of #include <M5Stack.h> works, so the device is fine.

    As with M5Unified.h not all functionality of M5Stack.h is supported yet, I NEED a working M5Stack library.

    So how to proceed?

    Thanks Marcus
    P.S.: same issue, see https://forum.m5stack.com/topic/5620/質問-m5stackライブラリをアップデートできません posted 2 weeks ago with no answer yet (so its not only me)

  • @maze2904
    Is this Arduino IDE 2.x.x?
    I am running
    Arduino IDE 2.2.1
    M5Stack library 0.4.5
    M5Stack board definition 2.0.7
    And I can program my Core Metal with no problems.
    Just did a comprehensive mod to my sketch, It compiles just fine!
    Hope my info helps.

  • @teastain
    Hi Terry,

    HW: M5Stack-Core-ESP32
    Arduino IDE 2.2.1
    M5Stack board definition 2.0.7
    my problem is: I can't install the library M5Stack, getting "Failed to install library: 'M5Stack:0.4.5'. No valid dependencies solution found: dependency 'MODULE_GRBL13.2' is not available"

    Thx, Marcus

  • @maze2904 OK, well now I think I understand.
    This is tricky...you may have a directory in your computer called:
    This is mine on a iMac...PC probably the same.
    Go to the m5stack folder and investigate the next level folders, such as ESP32 and the like.
    You may have to burn down (delete the whole structure of files!) the m5stack folder from "/Users/yourname/Library/Arduino15/packages/"
    and re-install the packages by letting the Arduino IDE see that the files are missing.
    You should consider first deleting your json link to the board defs:
    0_1694749977585_Arduino prefs.png
    To be sure that you have burnt the stack back down to
    "/Users/yourname/Library/Arduino15/packages/" and delete all files and folders from, and including:" m5stack > hardware > esp32>2.0.7" and any extraneous folders beyond m5stack. (Whew!)
    Hopefully the Arduino IDE board defs and libraries update function will restore all the dependancies, without any conflicts.
    M5Stack over on the AtomS3 GitHub repository advised me to do this and it worked(!) for a problem with my new AtomS3.

  • @teastain
    Hi Terry, et al

    thx 1M for your effort helping me!

    I've just found the work around:
    As per "M5Stack Library won't install on Arduino IDE", CitrusPeel identified the issue:

    The package's name "MODULE_GRBL13.2" in library.properties should be "MODULE_GRBL_13.2" (underline instead of space before 13.2).


    1. download M5Stack
    2. unzip it
    3. edit file "library.properties", line to "depends=M5Family,M5Module-4Relay,MODULE_GRBL_13.2,M5_BMM150"
    4. zip it and install zipped library
    5. restart IDE
    6. update now performed flawless

    @m5stack: awaiting M5Stack (0.4.6) to be released soon, as not all users having the knowledge on how to apply this "patch".

    Cheers, Marcus