How to flash tasmona or anything to M5Stack ATOM Lite using esptool?

  • Hi, I've tried so many things, but what is the correct way to flash a firmware to the M5Stack ATOM Lite ESP32 Development Kit using esptool? This (among many other commands) is not working --chip auto --port /dev/ttyUSB0 --baud 115200 --before default_reset --after hard_r^Cet write_flash -z --flash_mode dio --flash_freq 40m --flash_size detect 0x1000 /home/romeokienzler/Downloads/tasmota32.bin

    When I look at the serial monitor of the arduino IDE i get

    11:10:25.593 -> rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    11:10:25.593 -> configsip: 188777542, SPIWP:0xee
    11:10:25.593 -> clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    11:10:25.593 -> mode:DIO, clock div:2
    11:10:25.593 -> load:0x3f400020,len:289900
    11:10:25.958 -> ets Jun 8 2016 00:22:57 (edited)

  • Hello @romeokienzler

    M5Atom lite essentially is just another ESP32 based device so I'd guess the regular Tasmota instructions should work (not tested myself though). Have you tried the instructions here?

    Good luck!

  • @romeokienzler said in How to flash tasmona or anything to M5Stack ATOM Lite using esptool?:

    after hard_r^Cet

    Just to point out a possible issue, it looks I like you have a Control-C in your command by mistake. Is that a copy/paste error?

  • Dear @felmue and @world101 - I've followed the published instructions and also the ^C is only present in the post thanks for pointing that out. So until now I don't have a solution to my problem...

  • I have alsoo a problem with esptool

    Traceback (most recent call last):
    File "esptool\", line 94, in detect_chip
    File "esptool\", line 378, in check_command
    File "esptool\", line 347, in command
    File "esptool\", line 279, in read
    File "esptool\", line 1387, in slip_reader
    esptool.util.FatalError: Serial data stream stopped: Possible serial noise or corruption.

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "", line 34, in <module>
    File "", line 995, in main
    File "esptool_init
    .py", line 637, in main
    File "", line 880, in get_default_connected_device
    File "esptool\", line 121, in detect_chip
    File "esptool\", line 603, in connect
    File "esptool\", line 544, in _connect_attempt
    File "esptool\", line 407, in sync
    File "esptool\", line 323, in command
    File "serial\", line 372, in timeout
    File "serial\", line 222, in _reconfigure_port
    serial.serialutil.SerialException: Cannot configure port, something went wrong. Original message: PermissionError(13, 'A device attached to the system is not functioning.', None, 31)
    [6352] Failed to execute script 'esptool' due to unhandled exception!

    before clicking the burn button on m5burner, I push the button to enter boot mode green led is flashing