M5Dial can not upload

  • Hello there,

    I just bought my M5Dial, i uploaded the examples and everything worked correctly. I uploaded some simple code to write a string to the display, which worked correctly and still works when i reset the unit. The problem is, that i can not upload to the board anymore. Windows detects the device and I even have it among the ports in Arduino Ide, however during the ulpoad procces I get Failed uploading: uploading error: exit status 2 which indicates that connection could not be made. I can't even open the serial monitor. Is there a way to factory reset the device? Thank you kindly in advance for you suggestions.

    As you can see, the device is detected and connected:

    0_1706020525631_Screenshot 2024-01-23 153509.png

    This is the last code I have uploaded:

     * @file rfid.ino
     * @author SeanKwok (shaoxiang@m5stack.com)
     * @brief M5Dial RFID Test
     * @version 0.2
     * @date 2023-10-18
     * @Hardwares: M5Dial
     * @Platform Version: Arduino M5Stack Board Manager v2.0.7
     * @Dependent Library:
     * M5GFX: https://github.com/m5stack/M5GFX
     * M5Unified: https://github.com/m5stack/M5Unified
    #include "M5Dial.h"
    void setup() {
        auto cfgM5 = M5.config();
        M5Dial.begin(cfgM5, false, true);
        M5Dial.Display.drawString("unibox", M5Dial.Display.width() / 2,
                                  M5Dial.Display.height() / 2);
    void loop() {}

  • @smartvisionary The device is of course an S3, which has a permanent bootloader installed by Espressif at their factory, so it is 'brick-proof'.
    This error happens to me all the time and I see that there are three levels of loss, all with the same error message.

    1. unplug the device and plug it back in, try again.
    2. unplug and quit Arduino IDE and try again
    3. restart your computer, try again.

    Other techniques that generally work on S3 devices:
    Enter upload mode, two ways.
    Erase all flash before sketch upload: Enabled.
    Run a simple program with a timer delay and Serial Monitor with changinging messages to test if it is functioning.

    bool ticktock = true;
    void setup() {
    Serial.begin (115200);
    void loop() {
    ticktock = !ticktock;
      if (ticktock) {
      } else {
    delay (1000);

    Hope this helps, -Terry

  • try to open M5Burner and load latest firmware, my M5Dial went to some unresponsive mode few times, press and hold boot button under sticker usually helps before its plugged in to usb - it is then detected under different com port.

  • You have to hold it until a green light come on. I uploaded a video for the card computer which uses the same stampS3

  • @robski Where exactly is this button?

  • @jofotoo on the back next to the red grove connector

  • @jofotoo said in M5Dial can not upload:

    @robski Where exactly is this button?

    its under sticker in the middle (its shown on the sticker)
    pressing it just doesn't feel /sounds same as reset button,
    boot button is very delicate and hard to feel